Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The web-stat software Piwik stops reacting on mouse clicks after 1-2 seconds. The same is true for Google Maps and Producteev (but GMail and most other pages work like a charm). These rely heavily on JS, and work without Flash. I can click for a very short time period and then the mouse cursor doesn't feel the UI anymore (it doesn't turn into a I over input fields, though it moves; if the freeze occured while the pointer was over an input field, the cursor keeps being a I) and all clicks on the DOM are being ignored by Chrome. No message appears, neither obvious nor in the Console (F12). There is no obstructing div or the like in the DOM (F12). Since I couldn't find any hints on the source of my problems, I suspected my plugins and extensions.

Unfortunately, neither deactivating all plugins nor all extensions solved the problem.

  • for the problematic pages, it always happens
  • no Dropbox running
  • several GB of free RAM
  • the taskmanager doesn't show any high CPU or memory utilization (the offending tab uses 30 MB and uses 0-1 % CPU)
  • all problematic pages work in other browsers (Chrome, Firefox, IE)
  • the rest of the computer is very responsive
  • the computers use different security suites (Kaspersky and Avira)

The effect exists between several (synchronized) Chrome instances on different machines, all running Windows 7. Both the OS and Chrome are updated automatically. Other tabs and the Chrome chrome (tabs, menus, toolbar buttons of the browser itself) still work.

I really don't like switching between browsers. Any ideas?

share|improve this question
    
Two more pieces to the puzzle: (1) a new Windows user account doesn't have the problem. (2) When I launch Chrome with full administrative rights (using Sysinternals Process Explorer), Chrome works like a charm. So the problem comes from some interaction with other processes and not from Chrome itself. –  gogowitsch Oct 6 '12 at 18:30
add comment

2 Answers 2

up vote 1 down vote accepted

The cause turned out to be the following part of my AutoHotKey script:

~LButton::
  Enable_Window_Under_Cursor()
  Return

Enable_Window_Under_Cursor() ; By Raccoon 31-Aug-2010
{
  MouseGetPos,,, WinHndl, CtlHndl, 2
  WinGet, Style, Style, ahk_id %WinHndl%
  if (Style & 0x8000000) { ; WS_DISABLED.
    WinSet, Enable,, ahk_id %WinHndl%
  }
  WinGet, Style, Style, ahk_id %CtlHndl%
  if (Style & 0x8000000) { ; WS_DISABLED.
    WinSet, Enable,, ahk_id %CtlHndl%
  }
}

It allows me to continue typing or saving a document when a modal window is oben (such as the search window, or the ISTool compiler window). It is started by each left mouse button click.

Why it only broke a few sites in Chrome, and why Chrome seems to use a disabled control remains a mystery.

share|improve this answer
add comment

Horrible Assumptions: You've cleared the cache. Updated Java. Reinstalled Chrome.

Suggestions: Start with a fresh install of Java/Chrome without any other extensions or the like. Does it work? No: What does the Chrome Task Manage say about the problematic pages? You can also use the stats for nerds portion.

I've never had a problem with chrome on windows 7 like you are. Is Win7 up to date? Have you restarted with all start up items turned off? Or done any Optimization on windows 7? Who knows maybe there is something that is actually causing a problem with the DOM from somewhere else in the system.

I realize you have already done a lot of this, but it never hurts to double check in case something is missing. Let me know how some of the above helps, hurts, or aggravates, this is weird and I wouldn't mind getting to the bottom of it ^__^

[EDIT]: Oh, and obviously turn off any anti-virus or firewall that is on just to see if they are causing the problem. Not permanently mind you (be wary of sites you go to, I am not responsible for existing or future viruses that might infect the pc), but just long enough to see if there is a difference.

share|improve this answer
    
Thanks for your input. I've used your tipps, but it turned out to be entirely my fault (see answer below). –  gogowitsch Oct 7 '12 at 7:17
    
Well I am horribly curious to know what happened, to add it to the list of to do's in the event I run into the same issue XD –  Angel Brighteyes Oct 7 '12 at 7:23
    
Now that I know what the problem was, it seems highly unlikely that you ever experience it! Thanks again. –  gogowitsch Oct 7 '12 at 7:25
    
Haha, you never know. I would not have thought to ask about scripts that you might be running, now I will. –  Angel Brighteyes Oct 7 '12 at 7:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.