Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to update the firmware on my harddisk. I grabbed seagates windows setup tool which didnt boot into the app to update the firmware so I burned their iso image. Their ISO also doesnt boot and i vaguely remember something about windows not recognize my disc because of an EFI thing. It probably has nothing to do with it.

Anyways, how do I boot into the disc? I tried going into advance options to boot directly to the disc and i get a blank screen. I can use ctrl+alt+del which reboot the system but other then that its blank and doesnt seem to load anything on the disc. The disc was a 7mb iso burnt using windows 7 built in iso burner (it suggest using it on seagates site). I have no idea what to do. Do any of you guys know what my problem may be? The media is DVD-R

share|improve this question

1 Answer 1

Ensure a proper checksum, that the iso IS in fact bootable, your drive can read DVD's and lastly that the BIOS is configured to boot from CD first. I've also ran into cases where a drive would not recognize a specific brand of DVD - Maybe try another disc if the above fails.

share|improve this answer
    
It boots in VMWare and on a dell laptop. I burnt a Ubuntu Disc (as a live cd) on the same disc pack and it booted fine. I tried switching ahci to ide in my bios setting but that didnt help and i had to change it back so i could load my OS again. hmmmmm... i have no clue –  acidzombie24 Oct 6 '12 at 7:30
    
Interesting. You said it boots into a blank screen? Sounds like it may actually be loading but freezing shortly after. Maybe this question should be directed towards Seagates support forum if this is something critical you need to take care of. Just for kicks, try unplugging the HDD and boot into the cd - a bad or failing drive can cause bugs with programs attempting to access them. If this works, I recommend running their diagnostic software. –  Scandalist Oct 6 '12 at 16:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.