Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Dell Optiplex 745 with Windows 7 installed on it. I'm trying to use the Windows XP audio driver as Windows 7 drivers aren't available for Optiplex 745 and Windows Vista driver is displaying that it's not compatible with my hardware.

When I try to install the Windows XP audio driver, it's displaying an error

HDA audio bus driver is required and not found

The installation fails then.

I have researched thourghly and used many drivers but my audio is not working at all. I was also told that it might be a problem with my hardware – that is, a problem with the board.

share|improve this question
add comment

2 Answers 2

You might want to try the Windows Vista Drivers for your sound card instead:

Tom's Hardware forums proscribe a solution

share|improve this answer
    
Thanks for you support but as I mentioned in my question when I try to install windows vista driver, it displays a message that this driver is compatible with your hardware. Also please be noted that windows xp driver was working really nice for some time but after a few days of my windows 7 installation, it stop working and now all this happening as I mentioned in my question. –  user1666698 Oct 7 '12 at 4:32
    
You may wish to verify that, if your OS is 64-bit, that the 64-bit driver is the one you're using. If your OS is 32-bit, you will require the 32-bit driver. –  Ben West Oct 8 '12 at 16:09
    
en.community.dell.com/support-forums/desktop/f/3513/p/19322012/… May also be helpful. HAve you read the full post and replies in my article; there are several alternative processes posted. –  Ben West Oct 8 '12 at 16:14
    
My OS is 32-bit and I have also read this post but my problem still remained unresolved. –  user1666698 Oct 8 '12 at 17:09
1  
Did you try running the driver installer in compatibility mode? Also, why not use Windows' built-in HiDef audio driver? –  Bigbio2002 Dec 27 '12 at 23:43
add comment
  1. reboot
  2. go into the Dell BIOS (should be the F2 key)
  3. make sure that the integrated audio is enabled
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.