Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Fixing someone's Vista computer.

Process:

  1. I click any program or process that opens a User Account Control prompt.
  2. Screen goes dim so you may hit Continue to perform a secure user action.
  3. I click Continue
  4. Screen goes black for 30 seconds to 1 minute while you wait for the screen to return.
  5. In another example I click Cancel and screen still then goes black for 30 seconds to a minute.
  6. In that timeframe a chime goes off while you wait. (No chime if it was being cancelled.)
  7. Then screen comes back to continue with whatever.

Something is occurring after the UAC prompt. Considering everything is practically a UAC acceptance this can get pretty annoying pretty quickly.

  1. Laptop has external monitor to regular external plug. Works fine.
  2. Laptop also has USB IOGEAR additional external video card. This is problematic but when unplugged same above behaviour occurs.

I've ruled out monitor interference since same blackout after the UAC prompt appears with external monitors plugged in or when rebooted with no external monitors.

Any suggestions on how to address this problem?

share|improve this question
    
Screen goes black for 30 seconds to 1 minute while you wait for the screen to return. In that timeframe a chime goes off Very Kafkaesque. –  ta.speot.is Oct 7 '12 at 0:16
    
I'm turning off UAC and rebooting then turning it back on to see if that resets UAC. –  sf2k Oct 7 '12 at 0:44
    
Things are fine even with external monitors with UAC off. Need to find a way to see the driver for external monitor and elevate privileges for it? –  sf2k Oct 7 '12 at 1:02
    
Still after-delay when UAC on, regardless of monitors connected or not. :( –  sf2k Oct 7 '12 at 1:16
    
Does this delay occur when you press Ctrl+Alt+Delete and exit the Windows Security screen, or log onto your computer or unlock your session? If so, the problem is related to the Secure Desktop itself, not User Account Control. –  DragonLord Oct 7 '12 at 1:22

3 Answers 3

Why not disable the UAC on Vista and see if that works?

How to disable UAC : http://www.howtogeek.com/howto/windows-vista/disable-user-account-control-uac-the-easy-way-on-windows-vista/

share|improve this answer
1  
that's not an acceptable solution. That means anything can run admin privilege commands on your computer. The issue is a delay in the command not that the command doesn't work –  sf2k Oct 7 '12 at 0:58
    
-1: @sf2k is right. The answer you've given creates a significant security risk, because all user-space applications will run with administrator privileges, greatly increasing the impact of an attack against the user's computer. –  DragonLord Oct 7 '12 at 1:04
1  
@DragonLord I thought the real deal was to fix the issue here first. I agree disabling UAC may pose a big risk. I have UAC disabled on my Win7 laptop (constantly connected to net) since 2 years and never faced a problem. Might just be a personal experience. –  Anurag Oct 7 '12 at 1:16

I presume the problem is related to how your graphics card or driver handles screen switches. From your description, it seems to be not handling it that well. By default, UAC on Vista will do a screen switch to the "secure desktop" when asking for consent. It is possible to switch OFF the secure desktop switch, while still having UAC enabled.

You want to change the PromptOnSecureDesktop setting to 0. The Local Policy Editor can change that, but that's only available on Vista Business or "better". However, the registry setting can be changed regardless of Vista flavour.

Use this registry script:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"PromptOnSecureDesktop"=dword:00000000

Save this to a file with a .REG extension, and double click it, which will cause the Registry Editor to apply the setting.

The effect should become immediately active, without having to reboot or log off.

share|improve this answer
    
As noted in my comments above, in my case that setting in the registry was already set to zero and had no effect. TweakUAC was a good intermediary, I then upgraded the computer to Windows 7. Thanks for the input anyway. I had not put this step here. Someone might benefit from it if they haven't tried this method. –  sf2k Oct 19 '12 at 23:20
up vote 0 down vote accepted

In closing, "Quiet Mode" from TweakUAC was the best solution providing a non intrusive UAC authentication for Vista if the registry tweaks for PromptOnSecureDesktop failed. If you're stuck with lesser Vista Home editions and such I'd recommend this approach as UAC is still active for you. In my case I upgraded machine to Windows 7 and I have no further issues.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.