Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a desktop PC running Windows 7. I have connected an external stereo receiver and speakers to it and everything works fine when I test it in the Realtek Audio Sound through the control panel.

However, when I play a video or an audio CD, the stereo speakers do not work. I have line in, line out, and speakers connected to the receiver. I have been through the configure speakers portion also. Is there someplace else I need to configure?

share|improve this question

1 Answer 1

I have seen (well heard :-) the same problem here before, in that instance it was a stereo set of speakers comming out of what can be 5.1 or 7.1 type of outputs. (it was 2 sets of stereo speakers one set not working)

In the realtek hd control pannel (the software control pannel provided by realtek) the speakers were set for 4 channel, yet the video was only stereo. The audio jack was plugged into the "back speakers" for a 4 channel system, and I had deselected "SPEAKER FILL" which is a option in the realtek for passing stereo signals to all the speakers in the layout. This optional item was located in the same place that setting up the number of speakers and testing the speakers was in. (for a creative soundblaster system this fill items is called CMSS)

In that situation I could have moved the jack to the "front speakers" jack which is green colored jack I think.
I could use the "speaker fill" software option provided in the realtek software.
or potentially I could cross wire the thing with Y-adaption.

If your only ever going to have a single stereo 2 speaker setup running out of it, then it would probably be best to set the system to 2 channel only, and to tell the various softwares to "decode to stereo" to aleviate some of the other fun problems that can occur.

Other possibilities in windows own "speaker Properties" check the "Balance" in the "Levels" tab, this balance will effect the output to specific speakers.
Check also the Main windows volume controls by clicking on the little speaker in the taskbar, and clicking on the "Mixer" and checking that the "per-Application" volume setting for the specific program your playing is turned up.
CHeck also that the volume on the player your using is also turned up.

The rest of the possibilities gets thick with AC3 FFDshow and other codec (type) and Software based interceptions and controls in various programs and software which can "re-map" and adjust just about everything again. FFDshow codec filter thing can certannly change mapping and volume even though it is a "codec set" check out the volume and speaker mapping junk in it, if FFDshow is being applied as the decoder

Realtek also uses a detection system for what it thinks is plugged into the various jacks, when it works correct you can tell on the computer interface they provide where it thinks things are plugged in, if you did not even get testing to work, you should check the "jack" or connection section of thier software to see what it believes is (or is not) connected, and where it is connected to.

After all the STUFF sometimes it is nice to just have some sound :-) because your just setting it up , you will eventually find all the buttons , and even have good sound, and it will all be worth it.

Yes there are up to 7 different things that can effect the problem that you have, hopefully they are the easier ones.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.