Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using tunnelier client and server to connect to a windows machine. I can get in and have access to all of the files on the computer. I have vim installed on that windows machine, but I can't seem to edit anything via the DOS command line. I also tried editing in notepad, but nothing happens when I enter the command. I think this might be the part where DOS doesn't behave like bash.

Would I need to setup cygwin / openssh to accomplish this? (boo, tunnelier is so easy)

Thanks!

p.s. I know I could just use sftp and edit files that way, but it feels dirty.

share|improve this question
    
did you tried command line editor for DOS prompt called edit? It actually will look similarily to mcedit on linux. try it –  mnmnc Oct 8 '12 at 9:35
    
For one thing, I don't see how Notepad.exe could display on your local PC over an SSH connection. SSH can forward X11, but it's not Remote Desktop, unless Tuneler does something clever. Similarly, gvim.exe probably won't show up locally either. Have you tried running console-mode vim.exe instead? –  njd Apr 19 '13 at 13:19
add comment

1 Answer

up vote 0 down vote accepted

If you want to use vim from cmd.exe, make sure that the directory of the vim executable is in you $PATH.

Also make sure you use the terminal version (vim, not gvim) unless Tunneler does the Remote Desktop thing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.