Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 500 GB Toshiba external hard drive. Since yesterday Windows 7 stopped detecting it, however I do see it listed on the "Safely remove hardware and eject media" icon on the taskbar. Then I tried the same external hard drive on my Ubuntu and it detected it just fine. Ubuntu and Windows 7 are on the same laptop. I have dual boot.

Can someone tell me why is it happening? Am I missing a driver in Windows 7?

Additional info:

  1. This drive has worked perfectly fine in the past.
  2. I did not format this drive ever.
  3. It just stopped working yesterday in windows.
share|improve this question

migrated from Oct 7 '12 at 16:25

This question came from our site for system and network administrators.

what you mean it does not detect it? did you look into Disk Manager? – Serge Oct 7 '12 at 16:27
Right click on My Computer, go to disk management and tell us what the format of the disk is, when connected to windows. – AlanTuring Oct 7 '12 at 17:54
Disk management just hangs with the status "Loading disk configuration information..." when the drive is connected. It finally came up. Says "RAW". – unlimit Oct 8 '12 at 0:28

Go to Disk Management>Tools>Refresh Disk, if this does not detect anything it sounds like the drive is formatted in a format unsupported by Windows.

XFS disk formatting is not supported in Windows but is in Ubuntu.

share|improve this answer
Windows used to detect it till yesterday. My main question is why Windows can't but linux can? – unlimit Oct 8 '12 at 0:30
What does Linux say when you do this: sudo fdisk -l – UtahJarhead Oct 8 '12 at 20:35

To rule out a damaged disk, simply try it in another machine with windows.

If it works, the problem is in your windows installation. Try another drives to see if they work fine. Maybe a virus is preventing your windows to see the drive.

If it doesn't work in another windows machine, the problem is in the drive itself, maybe it got damaged, bad sectors, some corrupted files, or stuff like an unrecognized file system.

At least with that you can tell if the problem is the disk or windows. even if linux can read it, it may be damaged in such way that windows cant mount it properly.

Have you tried starting windows in safe mode to see if the drive starts properly?

share|improve this answer

I believe that the partition is damaged. I'm currently having the same issue.

If possible, back up all the data in Ubuntu, reformat the drive on Windows and then recover the data from Ubuntu.

I believe the issue is to do with a drive having been ejected incorrectly.

Trying to work on a fix as I have the same problem and there's a lot of data so it'd take quite a while to copy over.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .