Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to know if there is a way to remap certain characters to certain other keys in Mac OSX (by modifying a file or something).

I want to try out TextMate, but whenever I press Control + Alt + , (which is my sequence for ^<), it prints out this: "—"

Any way I could remap that somewhere else?

By the way, I'm using a mac mini on Snow Leopard with a windows usb keyboard, and my current keyboard layout is French Canadian CSA.

share|improve this question

2 Answers 2

up vote 5 down vote accepted

You have answered your question, but as a generic tool, Ukulele for OS X is a full unicode-aware keyboard map editor:

http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&item_id=ukelele

share|improve this answer

While looking for a character to place into Illustrator today, I noticed that the Keycaps character map utility is no longer to be found in OS X Panther (10.3). Poking around in Google, I found that this function is now handled through the Keyboard Viewer palette. getting this to show up takes a few steps though.

First, open System Preferences and show the International settings.

Second, select the Input Menu tab and check the Keyboard Palette checkbox. Check the menu box that reads "Show input menu in menu bar".

Now you will notice an icon in your system's top menu bar, probably the U.S. flag. This the input menu. When you click on the menu you can select "Show Keyboard Viewer" and the palette will open, allowing you to select a font and hold down Option, Shift, Command keys to view keyboard combinations.

share|improve this answer
    
I know about that, I used it to determine that there is a shortcut conflict. TextMate wants "^<" used for a shortcut, but to do so, I have to hit Ctrl +(option + , which produces <), but the whole combination produces a third character instead of the shortcut. I don't really need the produced — character, frankly. –  MrZombie Sep 29 '09 at 12:36
    
Oh nevermind. Seems I can customize the textmate shortcut. I must have seen it wrong yesterday. –  MrZombie Sep 29 '09 at 12:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.