Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am making acquiantance with wireless security and attacks and was told to run some tests with aircrack-ng and wireshark.

So I installed both of them and ran airmon to switch wi-fi card to monitor mode:

sudo airmon-ng start ra0 (this is my DWA-140 usb wi-fi adapter) The wi-fi adapter seems to have restarted after that. Gues that's ok.

After that I ran wireshark as a superuser, chose the ra0 adapter and tried to sniff the test open network. I have my PC connected to it (via dwa-140) and an HTC phone and some stranger PCs. Wireshark runs on my PC.

The problem is that when I login to %sitename% with a PC browser, I can see the cookies sent to it in Wireshark. But when I do the same thing with an Opera browser on my HTC, there is nothing detected. I know that stranger PCs are also sending data to %sitename%, but I see nothing from them as well. Still I see a lot of packets from stranger PCs, but not the ones I need.

I'd like to know what I'm doing wrong. Will be thankful for any advice.

P.S. This runs on Ubuntu 12.04.1

share|improve this question
up vote 0 down vote accepted

The issue was solved by installing an rt2800usb driver. Now monitor mode can be enabled, though sometimes the connection is lost.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .