Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Canon MP560. It is online, in the sense that

  1. I can connect to its internal web server.
  2. If I delete and reinstall it, Windows (Windows 7) will then recognize it.

In all other cases, neither my PC nor my Mac (purchased last week, running whatever is the latest and greatest Mac OS) recognizes that the printer is online.

The printer is statically configured to use the same IP address, so that's not an issue.

Because the printer works just fine with Windows after delete and re-add, I assume that the issue with the Mac is that I haven't installed whatever drivers Macs need to talk to Canon printers over a network.

share|improve this question
Do I understand correctly that you need to delete and re-add the printer to Windows every time that you wish to use it? Do you have the latest driver from here? – harrymc Jan 2 '13 at 9:49
@harrymc Yes and yes. – Marcin Jan 2 '13 at 23:36

One usual remedy to network printer driver problems is to :

  • Delete the printer
  • Connect printer via USB
  • Let Windows install the driver and verify that the printer does work correctly and keeps on working after a reboot
  • Convert this local printer to a network printer as in my other answer.
share|improve this answer

Not sure if this will be exactly relevant to your problem but if anyhow above answers doesn't works for you its worth giving a shot.

I have encountered a similar problem with my Wifi connection where windows used to use older authentication credentials while connection even when i have updated the passphrase key from network properties. Finally i always had to delete my older network and add it again with the new passkey.

So I guess my solution of the problem might work for you as well.

1) Delete the printer

2) Goto Run->'msconfig'->Click on Starup tab

See if any printer driver is added there.(If not, then I think this answer will not help you)

Uncheck that box.Reboot the system

3) Reinstall your printer now.

If this works,from now on your printer driver shouldn't give you any trouble.

share|improve this answer

For the windows PC, check that SNMP status polling is configured correctly, or disabled, on the Windows printer port. I've seen this cause issues on printers that don't implement SNMP properly, which is normally used to monitor network printers to see if they are online or offline.

To check this, you need to check the configuration of the the "port". Windows communicates with network-attached printers using "ports" - which is a legacy from way back when you could only connect printers directly to computers, using physical serial or LPT ports. For each network-attached printer, you will have a printer port pointing to the IP address of the printer.

You can see the printer ports on the system by:

  1. Click Start, and then click Devices and Printers
  2. Right-click the printer, and then click Printer Properties
  3. Click the Ports tab.

This will show all printer ports on the system. Find and select the port for the MP560, it will have a tick/check next to it, and should be named IP_

  1. Click Configure Port...
  2. Click to clear the SNMP Status Enabled check box, click OK, and then click Close.

For the Mac, I would make sure you install the drivers for the printer from Canon. Quite often OSX will pick a printer up, but won't be able to communicate with it, or use some of the advanced features of the printer (such as ink level monitoring) until you've got the right vendor drivers installed. Try the latest ones from the Canon website for this model. Consider grabbing a copy of the scanning and wireless setup utilities from the same page.

share|improve this answer
Thanks. Unfortunately, the port in question does not support configuration (hitting the button brings up an alert to that effect). – Marcin Jan 5 '13 at 19:04
What was the name and type of the port that the printer is configured to use? I ask because it might work with a different port type. – James Hebden Jan 5 '13 at 21:21
The port is a WSD Port. I'll try this with an IP port. – Marcin Jan 5 '13 at 21:36

Is the printer configured to "go to sleep" at all? I've had devices that would do this and NOTHING would get them back but a hard restart. I know that's slightly different from your situation, but I would look into it. If it does it may be in a twilight state.

share|improve this answer
Thanks for this. Do you have a good workaround beyond disabling sleep, and manually managing power? – Marcin Jan 4 '13 at 18:35
Check to see if there are firmware updates for the printer. That's how I solved the similar problem I had with a network device. – K.A Jan 5 '13 at 23:58

I think you should download the driver from the Canon website, and then leave it on your PC.

Next, totally uninstall the printer.

Now, instead of adding a printer, add a device and choose the driver. Now, reconnect the printer and hopefully it will detect fine and install without issue.

Reboot, see what happens.

If it still fails, it could be because the OS is trying to use it's own Windows Driver, so open up the printer in properties and ensure the correct driver is being used in the driver tab.

share|improve this answer

This link solved my problem: it is explaining How to setup printer static ip address:)

share|improve this answer
At the moment, this post is essentially only a link. To make sure the answer remains useful even if the link breaks, please edit it to include the relevant information. (Your answer was discovered in an effort to repair or remove old link-only answers.) – Ben N Jan 10 at 4:53

Connect to a "local printer" and add a TCP/IP Port with the IP address of the printer.

share|improve this answer
Can you add a bit more information on this and why it will solve the problem. – ChrisF Jan 8 '13 at 22:39

Ummm I think you just answered your own question. ....drivers can be a bit tricky to install make sure you turn anti-virus/firewalls off and install drivers before plugging in printer because you really can screw things up if you don't. I just got a canon pixma (mg) model printer it's wireless but does not have a LCD display or web interface for its internal web server but you will need to connect the printer itself to the same network as the windows 7 and any computers need to be connected to it as well. The instruction manual for my printer was on the actual installation disk and it was sort of challenging but there are actually several methods that can be used to connect the printer which involve plugging it into each computer individually and installing the printer with the USB cable attached. It may also be able to connect to your wireless via "WPS" the push button method which is kinda like pairing Bluetooth but not Bluetooth and it involves pushing and holding certain buttons on your devices to connect them . For me I had to fail installing drivers for it to offer me the info (which was very detail specific for my printer) and I was a little agitated that I could just navigate to a page with this info in paper or even PDF form.

share|improve this answer
Much of what you've written doesn't seem relevant, and breaking your post up into several paragraphs can make it easier to read. – bwDraco Oct 7 '12 at 23:40
To be clear: the printer works, and windows will recognise is as being online after windows re-adds the printer. None of the above is relevant, because the problem is that windows only recognises the printer as being online after it is reinstalled. – Marcin Oct 8 '12 at 0:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .