Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After my system is rebooted uncleanly, I faced some file system inconsistency on my 4TB software raid 5 partition (/dev/md3). So I tried fsck -y -f -v /dev/md3 several times.

Unfortunately the e2fsck exited with signal 7 command showed up every time. How can I fix this problem? The system refuses starting with this inconsistency. Regards.

share|improve this question
add comment

migrated from stackoverflow.com Oct 7 '12 at 23:06

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 2 down vote accepted

On Linux, signal 7 is the same thing as Bus error. This typically has one of two causes:

  1. You have a hardware problem with your motherboard, RAM or other critical system components. In this particular case, this is the most likely cause. Try moving the array to a known good computer, or at least attempting to isolate any bad hardware such as the motherboard, RAM or CPU.

  2. Your filesystem is so corrupt that something within it is causing fsck to crash. This is extremely unlikely with such a widely used tool, but is still within the realm of possibility. If you are 100% certain that you are using the drives in a PC with good hardware, contact the author of fsck (follow the Reporting Bugs process at the bottom of the page).

share|improve this answer
    
In case of 2, is it possible to recover some files from these raid hard drives? i need a way to copy some important file from this partition to a external storage. –  Ali n Oct 8 '12 at 10:41
    
Start with 1 first. –  Michael Hampton Oct 8 '12 at 13:24
    
It seems that my problem was with hardware, i dont know what caused this problem, Motherboard or Hard disk, but this problem fixed by unplug and replug all of SATA cables from motherboard and running "e2fsck -f -v /dev/md3" it showes some inconsistency and hopefully it succeeded with fixing them. –  Ali n Oct 12 '12 at 12:06
add comment

Have you tried a file-system check w/o the automated response? -y is a common reason of repair failing if the error condition is non-trivial.

share|improve this answer
    
what you meant by automated response? –  Ali n Oct 7 '12 at 19:50
    
without automated response == Without the -y option to fsck ... –  Basile Starynkevitch Oct 7 '12 at 20:11
    
yeah, i did that, nothing specific happend. –  Ali n Oct 7 '12 at 20:13
    
Check with dmesg and smartctl if your disk is healthy, it might be dying.... Then use (or, if lucky, make) a backup after changing the disk. –  Basile Starynkevitch Oct 7 '12 at 20:28
    
"mdadm --details" showed that all raid drives are healthy... –  Ali n Oct 7 '12 at 20:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.