Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to configure iptables for ubuntu 10.04 and I have a problem with iptables -L lagging on rows where the destination or source address is not localhost or anywhere. The following entries will cause lag on their row:

iptables -A INPUT -p tcp --dport 111-s 192.168.1.14 -j ACCEPT
iptables -A INPUT -p tcp --dport 90 -d 192.168.1.14 -j ACCEPT

while this does not:

iptables -A INPUT -p tcp --dport 111 -j ACCEPT
iptables -A INPUT -p tcp --dport 90 -j ACCEPT

I feel like this might be due to iptables checking to see if the ip is reachable. If not, what is the cause, if it is how can I disable it?

share|improve this question
up vote 2 down vote accepted

It's trying to resolve addresses to hostnames. Adding -n will prevent this.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .