Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install mplayer with OSD using homebrew. I've added both --enable-menu and --with-freetype-config=/usr/local/Cellar/freetype/2.4.10/freetype-config to the brew recipe.

==> Downloading http://www.mplayerhq.hu/MPlayer/releases/MPlayer-1.1.tar.xz
Already downloaded: /Library/Caches/Homebrew/mplayer-1.1.tar.xz
xz -dc "/Library/Caches/Homebrew/mplayer-1.1.tar.xz" | /usr/bin/tar xf -
==> ./configure --prefix=/usr/local/Cellar/mplayer/1.1 --cc=cc --host-cc=cc --disable-cdparanoia --disable-libopenjpeg --enable-menu --disable-x11 --     with-freetype-config=/usr/local/Cellar/freetype/2.4.10/freetype-config
./configure --prefix=/usr/local/Cellar/mplayer/1.1 --cc=cc --host-cc=cc --disable-cdparanoia --disable-libopenjpeg --enable-menu --disable-x11 --with     -freetype-config=/usr/local/Cellar/freetype/2.4.10/freetype-config
Checking for cc version ... clang 4.2.1 (experimental support only)
Checking for working compiler ... yes
Detected operating system: Darwin
Detected host architecture: x86_64
Checking for cross compilation ... no
Checking for host cc ... cc
Checking for CPU vendor ... GenuineIntel (6:15:10)
Checking for CPU type ...  Intel(R) Core(TM)2 Duo CPU     T7700  @ 2.40GHz

For freetype-config I've tried three seperate paths; /usr/X11R6/bin/freetype-config, /usr/X11/bin/freetype-config and the one in Cellar.

Checking for freetype always fails:

Checking for freetype >= 2.0.9 ... no
Checking for fontconfig ... no (FreeType support needed)

Although freetype itself seems to be installed.

mufasa:bin eythor$ freetype-config --version
15.0.9
mufasa:bin eythor$ freetype-config --ftversion
2.4.10
mufasa:bin eythor$ freetype-config --libs
-L/usr/local/Cellar/freetype/2.4.10/lib -lfreetype -lz -lbz2
mufasa:bin eythor$ freetype-config --cflags
-I/usr/local/Cellar/freetype/2.4.10/include/freetype2 -          I/usr/local/Cellar/freetype/2.4.10/include

I'm not sure what to try next or how to figure out why freetype isn't recognized.

Can anyone point me in a sensible direction?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I was having this issue too. The following worked for me on OS 10.8.

  1. First remove mplayer.

    brew remove mplayer
    
  2. Then install mplayer using the mplayer.rb formula from this GitHub pull request from camillol https://github.com/mxcl/homebrew/pull/16122.

    brew install https://raw.github.com/camillol/homebrew/e888a6c45738dbeb0a6816f0e23f5cb66df0563c/Library/Formula/mplayer.rb
    
share|improve this answer
    
Hey great! Thanks! –  eythor Nov 27 '12 at 23:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.