Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got NoVNC running on Centos 6, and I can connect to it from my web browser without any problems. From some locations the connection is a bit slow, and I'd like to be able to drop back to 8 bit color mode from full color mode. But when I deselect true color from the NoVNC options menu, I get a message saying:

Tight protocol handler only implements true color mode

I have worked around this by commenting out TIGHT from the encodings array in rfb.js, like so:

encodings      = [
    ['COPYRECT',         0x01 ],
    //['TIGHT',            0x07 ],
    ['TIGHT_PNG',        -260 ],
    ['HEXTILE',          0x05 ],
    ['RRE',              0x02 ],
    ['RAW',              0x00 ],
    ['DesktopSize',      -223 ],
    ['Cursor',           -239 ],

This will let the NoVNC client fall back to HEXTILE, which will allow non-true color mode. But is there some less hacky way to fall back to 8 bit color mode with NoVNC?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I just pushed a fix that will fall-back to hextile if true color is disabled: https://github.com/kanaka/noVNC/commit/c95456c0e136109447017a43c1cfc5f9ca363b6b

However, note that this probably isn't what you want. 8-bit hextile takes more bandwidth than 24-bit true color tight encoding and my guess is that it will also generally render slower.

The least hacky approach is for somebody to implement 8-bit colour mapped mode for the tight encoding in noVNC. Unfortunately, I don't have time to attack this. Any takes?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.