Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Fedora on a laptop with external display via VGA. (the internal one is disabled, but will open when it is booting up)

Internal 1024*400, External 1920*1080.

The resolution is normal under Xfce, but sometimes I need to use the command line interface, via control + alt + f1-7, and the terminal can not fullscreen, only occupy a corner of the screen.

I tried xrandr, but it says "can't open display"

How can I make the terminal full screen?

share|improve this question
    
You know you can just open a terminal in xfce without falling to a tty (ctr+alt+F keys) right? –  terdon Oct 8 '12 at 9:14

1 Answer 1

up vote 1 down vote accepted

Generally you need to change the framebuffer settings, and this depends on the version of grub that is being used (or, which Fedora version you are running). If it is grub2, I think you can follow this forum entry.

Following a comment by Denis, here is a summary of the solution in the reference link:

1) Add "video=1024x768@60" to the parameters of the kernel command line in /boot/grub2/grub.cfg (substitute the resolution you want, of course).

2) This will be replaced when grub2 updates, and to make it permanent, edit /etc/grub.d/00_header to include the following line around line 40:

if [ "x${GRUB_GFXMODE}" = "x" ] ; then GRUB_GFXMODE=1024x768@60 ; fi

and run update-grub2 which should at the entry to /boot/grub2/grub.cfg.

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  sudo Jan 30 '13 at 13:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.