Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When few devices are connected to my router, nothing happens. However, when more than 10 devices are connected, the router resets itself or I have to reset it myself.

Is this a problem with the router itself or is there some setting I need to configure to allow more devices on the router?

share|improve this question
    
What is the make and model of your router? –  David Schwartz Oct 8 '12 at 8:14
add comment

2 Answers

up vote 2 down vote accepted

The configuration you're talking about most likely doesn't exist.

Hardware restarting itself is usually because of:

  • Bad drivers.
  • Heat issues.

You could try:

  • Updating firmware.
  • Cooling the router in some way.
share|improve this answer
    
have placed it on a point higher than the table sureface and have updated the firmware - will give it a day and get back. –  Arvind Sridharan Oct 8 '12 at 10:31
add comment

I had the same issue - when my PC was on, all worked, but when I had multiple peripherals it failed. It was almost as if the router just couldn't handle it all.

It turned out to be that - the router was cheap and couldn't deal with something (maybe the amount of traffic / dealing with the DHCP / etc).

Therefore, on top of TFM's good suggestions, can you try a different router because quite frankly if the router isn't up to it, then nothing will help other than a replacement.

share|improve this answer
1  
I agree with Dave. Firmwares are not updated as soon often as one should expect, and handling the cooling issues is not practical. A router should have decent cooling, as you are not supposed to attach a CPU cooler to it. –  TFM Oct 8 '12 at 7:51
    
the router was on my table which was heating up quite a lot. Have kept it slightly higher than the surface with some makeshift stands. lets see if this helps. If it doesn't, I will look into the firmware and getting a new router. –  Arvind Sridharan Oct 8 '12 at 8:37
    
@ArvindSridharan - I agree, follow TFM's suggestion first (mostly because they're quick and easy to implement and free!) –  Dave Rook Oct 8 '12 at 9:02
    
have updated the firmware - will give it a day and get back. –  Arvind Sridharan Oct 8 '12 at 10:24
    
@DaveRook - done! –  Arvind Sridharan Oct 8 '12 at 10:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.