Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I already posted in serverfault, but was closed due off-topic:

At this point I can't connect to internet from my RPi. I ask this question here and not in raspberrypi.stackexchange.com because this problem is about networking and not about the device.

To resume:

I did the following steps: http://forums.opensuse.org/english/get-technical-help-here/network-internet/454678-how-create-network-bridge-2.html#post2295540

Then, I could connect to my RPi via SSH, but I was unable to ping or resolve to google.com, so I did some steps for IP Masquerading:

http://www.ibiblio.org/pub/linux/docs/HOWTO/other-formats/html_single/Masquerading-Simple-HOWTO.html

Now I can ping from my RPi to my PC and from my PC to RPi, but from my RPi to Google.com it just resolve but doesn't receive any packets from ping:

PING www.google.com (187.141.135.216) 56(84) bytes of data. ^C
--- www.google.com ping statistics 
--- 9 packets transmitted, 0 received, 100% packet loss, time 8000ms

I don't know what I'm missing to do.

These are my iptables rules in my PC:

sudo /usr/sbin/iptables -t nat -L
Chain PREROUTING (policy ACCEPT)
target     prot opt source               destination         

Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Chain POSTROUTING (policy ACCEPT)
target     prot opt source               destination 
share|improve this question
    
What happens when you traceroute out? What are your current IP address assignments, routes, and iptables configuration? –  David Schwartz Oct 8 '12 at 10:04
    
traceroute to www.google.com (187.141.135.236), 30 hops max, 60 byte packets 1 * * * 2 * * * 3 * * * 4 * * * 5 * * * 6 * * * 7 * * * 8 * * * 9 * * * 10 * * * 11 * * * 12 * * * 13 * * * 14 * * * 15 * * * 16 * * * 17 * * * 18 * * * 19 * * * 20 * * * 21 * * * 22 * * * 23 * * * 24 * * * 25 * * * 26 * * * 27 * * * 28 * * * 29 * * * 30 * * * –  Mr_LinDowsMac Oct 8 '12 at 10:05
    
That's odd. Your first hop doesn't even work. Do you have a default route on the pi? –  David Schwartz Oct 8 '12 at 10:06
    
@DavidSchwarts I don't understand what do you mean with 'default route' –  Mr_LinDowsMac Oct 8 '12 at 10:11
    
The "default route" specifies where packets go to if they don't match any of the other routes. What is the output of ip route on the pi? –  David Schwartz Oct 8 '12 at 10:16

1 Answer 1

up vote 0 down vote accepted

I found the solution here:

http://lists.opensuse.org/opensuse/2005-10/msg02384.html

The solution does not involve IP masquerading; it only has to do with IP forwarding. First we enable IP routing in YaST or by manually editing /etc/sysconfig/SuSEfirewall2 and setting FW_ROUTE="yes".

Then we have to manually set FW_FORWARD="192.168.0.0/24,0/0". "0/0" is the heart of every network in the computer. "

In my case was FW_FORWARD="10.42.43.255/24,0/0", rebooted device and worked :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.