Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, I followed this tutorial...

It seems that it worked fine. When I type in

echo $SHELL and echo $BASH_VERSION

I get

"/usr/local/bin/bash" and "4.0.0(1)-release" .

But, when I simply run "bash" I get shells command line with "bash-3.2$" (not sure if this is important?) and when I try to install RVM (which is my main reason for doing the upgrade in the first place) I still get the

BASH 3.2.25 required (you have 3.2.17(1)-release)

error.

share|improve this question

migrated from stackoverflow.com Oct 8 '12 at 12:10

This question came from our site for professional and enthusiast programmers.

    
Your installation of OS X is quite old, isn't it? On 10.6.8, /bin/bash has the version 3.2.48(1)-release. Anyway, the tutorial you linked to was written 3 years ago, and the latest release of Bash is 4.2.37. You may want to install that. –  Percival Ulysses Oct 8 '12 at 15:21

1 Answer 1

up vote 1 down vote accepted

This is because /bin/bash takes precedence over /usr/local/bin/bash in your $PATH. Thus, when you simply write bash, it'll load the former instead of the more recent version.

To fix this, you will need to edit your ~/.bash_profile and add:

export PATH=/usr/local/bin:$PATH

Save the file, and reload your shell (e.g. by exiting the Terminal). Now, any call to bash should use the version in /usr/local/bin instead.

share|improve this answer
    
Here is a documentation about the PATH variable, at the end OS X is discussed. You can also edit /etc/paths (provided you have administrator rights) and put the line /usr/local/bin above the line /bin so that the binaries in /usr/local/bin have precedence. –  Percival Ulysses Oct 8 '12 at 13:13
    
That's true, but I'd personally rather not change system files for these kinds of per-user tasks. –  slhck Oct 8 '12 at 13:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.