Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to install mysql-devel package by doing

/usr/bin/yum install -y --disablerepo=* --enablerepo=base mysql-devel

It fails with the following errors.

...
...
--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.80.el6.i686 (base)
           Requires: glibc-common = 2.12-1.80.el6
           Installed: glibc-common-2.12-1.80.el6_3.5.x86_64 (@updates)
               glibc-common = 2.12-1.80.el6_3.5
           Available: glibc-common-2.12-1.80.el6.x86_64 (base)
               glibc-common = 2.12-1.80.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

What does that mean? I can't seem to make out.

share|improve this question

2 Answers 2

This is presumably an x86_62 system, running x86_64 CentOS. It is trying to install the i686 package for glibc, which depends on glibc-common. You have a newer glibc-common for x86_64 than the i686 one required by mysql-devel, and as the packages for the different architectures must be strictly synchronized the install fails. Why it wants the i686 one for mysql-devel beats me.

Have you tried to update the system fully before trying again? It might be that you were unlucky and the i686 updates hadn't shown up yet. You might try with:

yum clean metadata # Cleans out the cache of latest versions and such for yum

yum -y update --skip-broken # Should update everything

yum install mysql-devel

If that still fails, details of the commands used and full output would presumably help in diagnosing the problem.

Consider installing yum-utils, the package-cleanup program helps keeping the system clean (free of leftover pieces from failed updates and such).

share|improve this answer
    
It has been long since I had this error. I don't even remember how I solved it & also the name of the hostname of the server where this error was there. So, sorry, can't do anything here. Anyways, thanks for the reply. I'll keep this in mind. –  shadyabhi Feb 2 '13 at 7:34

I think it's looking for the x86 package, whereas you have the x64 package.

Try directly running

yum install glibc-2.12-1.80.el6

or

yum install glibc-2.12-1.80.el6.i686
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.