Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am encountering a really weird problem on my WD Caviar Green HDD. Well first of all I have 2 HDDs on my Desktop, one 160GB Seagate holding my Win7 Ultimate x64 and the problematic one, WD 1.5 Caviar Green for storage purpose.

My problem is kinda weird, when I transfer files from my Seagate(C:) to my WD (D:) the speed is good (50-60MB/s). Then the problem arises when I transfer too "many" large files, the transfer speed would go straight down to kilobytes/s. Well after I cancelled the transfer and access my D:, even entering a folder requires loading for like 10 seconds.

Such problem not only arises when I am transferring files to my D:, it seems like my WD can't handle much activities. For instance, last time I installed my game on D: and I would face much lag after playing for some time. When the same game is installed on C: no problem arises.

Does anyone knows what is the problem?

P/S: There was one temporary solution that I used to tried. After the "situation" occurs, I tried to access as many folders on D: as I can and let it load, repeating such actions and giving it some time bring the D: back to speedy transfer. However, large transfers would causes the situation to happen again. Does it have something to do with cache whatsoever?

share|improve this question
1  
First, i would suggest to get a program to display the SMART data of your HDD. It will let us verify that the HDD is healthy, and also inform us about eventual corrupted sector. Other things that could be useful to add to your post: - What filesystem are you using ? Each filesystems has it's own characteristics so it may be an issue in some cases. - How is this hard drive connected in your computer ? –  TeT Oct 8 '12 at 15:05
    
The thing is I tried running diagnostic tools from WD performing a "Extended Test" I kinda passed the SMART test. I am using NTFS as it is an internal drive (WD15EADS). –  Steven Oct 11 '12 at 10:34
    
I have exactly the same problem with my 1.5TB Caviar Green drive. Transferring a large 4GB file, or multiple 1TB files starts at 80mb/s for a few seconds, then drops to 10mb/s for the remainder of the transfer. Performed a WD diag test and every thing passed. I am suspecting the drive could die at any moment now. –  azgolfer Nov 14 '12 at 15:14
add comment

2 Answers 2

Green drives are not known for their performance - They achieve 'green' status by running slow, but efficiently. It sounds like the Seagate is considerably faster than the WD drive. If that's the case, then what is happening is Windows will "copy" at the rate at which it can read data off of the Seagate drive into memory. The data will then sit in memory in a disk cache, and will be written out to the WD as fast as it can - but if it's slow, this will take a while, and it will max out the WD drive, which is why folder browsing takes so long until the system is done flushing out the cache.

I would grab a S.M.A.R.T. utility and check the drive health, and then possibly a benchmark tool to test the raw read/write speed of the drive. Poor performance can be indicative of a failing drive (i.e., because it has a lot of relocated sectors, and those sectors take additional time to redirect when reading them).

share|improve this answer
    
Well the thing is I am only able to run benchmark tools (HD Tune) on my WD when it is "okay". The read/write speed are roughly the same with my Seagate. However when the situation mentioned above arises, I would face extreme lag when I am trying to point my benchmark tools to the drive. In other words, when the situation arises, anything I do related to the D: suffers extreme and severe lag. –  Steven Oct 9 '12 at 10:55
    
@Steven Then I'd say either the harddrive is failing, the motherboard's controller is failing, or they are incompatible. Test the drive in another system and see if you get the same behavior. –  Darth Android Oct 9 '12 at 15:27
add comment

If your drive has the type WD15EADS-00P8B0 it could simply be the known issue with these drives. From time to time this drive seems to slow or freeze, Win8/Linux shows 100% Disk utilization and a read speed of <1MB/s. It makes Windows unusable if the disk is a system drive.

http://community.wd.com/t5/Desktop-Mobile-Drives/WD15EADS-00P8B0-Really-slow-Or-am-I-just-crazy/td-p/1547

There is no definite fix for it. One person reported success by disabling 6Gb/s transfer speeds and switching to 3Gb/s, another person claims the drive simply runs in PIO 4 without DMA and enabling that helps till the next reboot. I still need to try these on my drive.

You could try to RMA your hard disk. WD apparently claims the drives are fine and ignores the issue, but processes RMA's.

I'll think twice next time before buying a WD drive.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.