Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ever since switching to VS 2012, I have a frequently occurring issue where dropbox tries to sync files as VS 2012 is creating them (when adding a project, installing nuget packages, etc...). VS fails because the file(s) are locked. Has anyone else experienced this issue? Is there a way to configure Dropbox to delay sync by a few seconds or some other work around?

share|improve this question

migrated from programmers.stackexchange.com Oct 8 '12 at 15:59

This question came from our site for professional programmers interested in conceptual questions about software development.

Sounds more like something you should suggest to the dropbox devs. I don't think something like Dropbox should lock files at all - if they are modified while being synced it should handle it in a transparent way. –  ThiefMaster Oct 8 '12 at 16:08
@ThiefMaster: I have a feeling Dropbox locks the file just to create some sort of hash to compare with what's on the server. The problem is intermittent because of the race condition of VS 2012 trying to lock the file when it creates it and Dropbox apparently trying to lock anything the second it's created or modified. For me, I see it all the time when compiling the Debug build and VS 2012 complains it can't open the pdb file. –  pelesl Jul 7 at 1:37
@pelesl I see it mostly when rolling back or updating nuget packages with dependencies, but I do see the pdb issue as well. I've since moved on to OneDrive, and I noticed they seem to have a delay in processing changed files. Maybe it was intentional design, or just a byproduct of something else, but it has eliminated this issue, for me. –  Chris Jul 8 at 1:03

1 Answer 1

The only alternative for now is to pause syncing while you're working on Visual Studio. Dropbox doesn't have an option now to delay sync. You can pause syncing by right clicking the Dropbox icon & then choose "Pause syncing"

enter image description here

share|improve this answer
This kills the sync. Is there any workaround to change VS 2012 behavior in creating files? Apparently OP haven't have such problem with VS 2010, I suppose. –  Isaac Oct 13 '12 at 20:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.