Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to share my Macs WiFi connection to a linksys wrt54g router but nothing seems to be working.

When I plug the ethernet cord from the Mac into the internet port of the router the ethernet icon is yellow and gives me the following error: Ethernet has a self-assigned IP address and will not be able to connect to the internet.

I have my Wifi connect sharing to the ethernet port properly. Here are the fixes i've attemped:

  • Reset the router to factory settings
  • Tried turning off the Passive FTP option in the advance->proxies tab of both ethernet and Wifi
  • Tried deleting com.apple.alf.plist and rebooting the computer
  • Tried setting the router from a gateway to a router setting and plugging the wire both into the internet port and a standard lan port with no success

Any ideas why the router is not working with the internet sharing?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.