Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ping to e.g. my router on 192.168.1.1 or to google.com are fine, but ping to either 127.0.0.1, localhost or ::1 results in:

C:\>ping 127.0.0.1

Pinging 127.0.0.1 with 32 bytes of data:

General failure.
General failure.
General failure.
General failure.

Ping statistics for 127.0.0.1:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

I have activated Windows Firewall dropped packet logs. Here is the result:

#Fields: date time action protocol src-ip dst-ip src-port dst-port size tcpflags tcpsyn tcpack tcpwin icmptype icmpcode info path
2012-10-08 16:36:55 DROP TCP 127.0.0.1 127.0.0.1 4383 443 48 S 1694698661 0 8192 - - - RECEIVE
2012-10-08 16:37:07 DROP TCP 127.0.0.1 127.0.0.1 4389 80 52 S 3914643729 0 8192 - - - RECEIVE
2012-10-08 16:34:49 DROP UDP 127.0.0.1 127.0.0.1 51995 51996 30 - - - - - - - RECEIVE
2012-10-08 16:34:49 DROP UDP 127.0.0.1 127.0.0.1 51997 51998 30 - - - - - - - RECEIVE
2012-10-08 16:34:49 DROP UDP 127.0.0.1 127.0.0.1 51999 52000 30 - - - - - - - RECEIVE
2012-10-08 16:34:56 DROP ICMP 127.0.0.1 127.0.0.1 - - 60 - - - - 8 0 - RECEIVE
2012-10-08 16:34:57 DROP ICMP 127.0.0.1 127.0.0.1 - - 60 - - - - 8 0 - RECEIVE
2012-10-08 16:34:58 DROP ICMP 127.0.0.1 127.0.0.1 - - 60 - - - - 8 0 - RECEIVE

It seems as all incoming packets are dropped. But I can browse, write and receive emails and so on.

I tried already resetting IP/TCP stack by:

  • netsh int ip reset
  • netsh winsock reset
  • route /f
  • ipconfig /reset, ipconfig /renew

The ping result doesn't change if I disable the firewall.

share|improve this question

1 Answer 1

Ping is a service that a system can implement or not (in fact some routers and systems do not ping back as to remain hidden from attempts scanning the networks for computers).

It appears this needs to be enabled in Windows-7 as per instructions here.

To wit:

Control Panel --> System and security --> Windows Firewall --> Advanced settings --> 
Inbound rules --> New rule --> custom rule

in Protocol and ports: Protocol: ICMPv4
on the same panel go to customize, choose "Specific ICMP types", 
check the box "echo request"
share|improve this answer
    
That's not the problem. I already enabled the rule, which exists by default and the problem persist if I disable the windows firewall completely. But thanks. –  user1349542215 Oct 8 '12 at 18:54
    
Sorry, missed the part in your post about the firewall –  collaborator Oct 8 '12 at 19:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.