Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently put #!, a linux distro based on Debian, on my computer. All the installation process was OK, but finally, when I switched it on, I saw there wasn't written anything about the WiFi connection in the bar. So I ran:

iwconfig
ifconfig

And I got the following results:

shoyip@shoichi-crunchbang:~$ iwconfig

lo no wireless extensions.
eth0 no wireless extensions.
pan0 no wireless extensions.

shoyip@shoichi-crunchbang:~$ ifconfig
eth0 Link encap:Ethernet HWaddr e8:9a:8f:68:a6:d2
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:29 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:64 errors:0 dropped:0 overruns:0 frame:0
TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5184 (5.0 KiB) TX bytes:5184 (5.0 KiB)

shoyip@shoichi-crunchbang:~$ lspci 00:00.0 Host bridge: Advanced Micro
Devices [AMD] RS880 Host Bridge 00:01.0 PCI bridge: Advanced Micro
Devices [AMD] RS780 PCI to PCI bridge (int gfx) 00:05.0 PCI bridge:
Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA
Controller [AHCI mode] (rev 40) 00:12.0 USB Controller: ATI
Technologies Inc SB700/SB800 USB OHCI0 Controller 00:12.2 USB
Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0
Controller 00:13.2 USB Controller: ATI Technologies Inc SB700/SB800
USB EHCI Controller 00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus
Controller (rev 42) 00:14.2 Audio device: ATI Technologies Inc SBx00
Azalia (Intel HDA) (rev 40) 00:14.3 ISA bridge: ATI Technologies Inc
SB700/SB800 LPC host controller (rev 40) 00:14.4 PCI bridge: ATI
Technologies Inc SBx00 PCI to PCI Bridge (rev 40) 00:14.5 USB
Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:15.0 PCI bridge: ATI Technologies Inc Device 43a0 00:15.1 PCI
bridge: ATI Technologies Inc Device 43a1 00:15.2 PCI bridge: ATI
Technologies Inc Device 43a2 00:15.3 PCI bridge: ATI Technologies Inc
Device 43a3 00:16.0 USB Controller: ATI Technologies Inc SB700/SB800
USB OHCI0 Controller 00:16.2 USB Controller: ATI Technologies Inc
SB700/SB800 USB EHCI Controller 00:18.0 Host bridge: Advanced Micro
Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor
Address Map 00:18.2 Host bridge: Advanced Micro Devices [AMD] Family
10h Processor DRAM Controller 00:18.3 Host bridge: Advanced Micro
Devices [AMD] Family 10h Processor Miscellaneous Control 00:18.4 Host
bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc M880G
[Mobility Radeon HD 4200] 02:00.0 Ethernet controller: Realtek
Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet
controller (rev 06) 04:00.0 Network controller: RaLink Device 5390
shoyip@shoichi-crunchbang:~$ lsmod | grep rt2860sta
shoyip@shoichi-crunchbang:~$

I followed these instructions, then these(I used Google Translate to understand it), but still no WiFi connection. What i have to do? Thanks in advance, Sho.

share|improve this question
    
Could you please tell us some more about what you actually did? Also, please post the output of the commands you ran. What is your hardware? The 2nd link you gave (the first is in German which I do not speak) is about a specific chipset, is that what your card has? –  terdon Oct 8 '12 at 19:53
    
I've installed crunchbang on my computer, but it doesn't detect my wlan adapter. Running lspci I get 04:00.0 Network controller: RaLink Device 5390, so I am quite sure that it's talking about my card. Iwconfig: lo no wireless extension eth0 no wireless extension pan0 no wireless extension. Ifconfig: Seth0 link encap: Ethernet hwaddr e8:9a:8f:68:a6:d2 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets... lo Link encap:local loopback inet addr:127.0.0.1 Mask:255.0.0.0 –  shoyip Oct 9 '12 at 12:57
    
Please update your question with the output of these commands, it makes it much easier to understand. Ideally, we would like to see each command you have run. Giving a link to instructions in a different language that you claim to have followed is not very helpful. Also, please post the output of lsmod | grep rt2860sta. –  terdon Oct 9 '12 at 13:21
    
OK, I will switch on #!, then I'll post the outputs. –  shoyip Oct 9 '12 at 13:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.