Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is not a duplicate of this question

I watch videos on YouTube, Netflix, etc. Whenever I enter full-screen mode, I get the annoying "You've entered full screen mode. Press 'esc' to exit full screen mode".

Since I'm constantly switching between programs, I see this message a lot and am severely annoyed by it. Is there a way to disable these notifications?

share|improve this question

2 Answers 2

up vote 2 down vote accepted


For Windows, download and install this patch as per the instructions here

For Mac OS X (requires a windows PC):

  1. Goto /Library/Internet Plug-Ins/
  2. Open* Flash Player.plugin
  3. In Flash Player.plugin goto Contents > PlugIns
  4. Open* FlashPlayer-{Your Mac OS Version}.plugin (Example: My file was "FlashPlayer-10.4-10.5.plugin" for Mac OS 10.5.5)
  5. In FlashPlayer-{Your Mac OS Version}.plugin goto Contents > MacOS
  6. Copy FlashPlayer-{Your Mac OS Version} and patch it using the "Other" option in my program on a computer with windows.
  7. Copy back the patched FlashPlayer-{Your Mac OS Version} into the folder.
share|improve this answer
I feel unconfortable, to say the least, applying a random patch to Flash. – That Brazilian Guy Aug 7 '13 at 21:02
@ThatBrazilianGuy: I found a few solutions that do not require patching Flash. See my answer. – miyalys Sep 22 at 12:05

For Firefox there are a couple of other solutions for this problem, but for Chrome I have not been able to find any.

Note: The warning is there for security reasons, because sites can otherwise - via JavaScript - automatically fullscreen themselves, and for instance disguise themselves as your desktop, while intercepting user input.
This is particularly an issue as these solutions also disable the first, related popup that asks you whether you want to allow or deny the website to put you in fullscreen, not just the notification shown after allowing a site to go into fullscreen.


1: Via about:config

  1. Type in about:config into the navigation bar and press enter.
  2. Search for the value full-screen-api.approval-required and set it to false.

2: Via a plugin

Install the Firefox plugin Disable HTML Fullscreen Alert.

share|improve this answer
This doesn't seem to work on Google Chrome. Would you happen to have instructions for Chrome as well? – inspectorG4dget Sep 24 at 3:49
You're right, it's not a general solution, though I expect looking into browser specific solutions is in general a good idea. I have found some suggestions for Chrome, like kiosk mode and white- isting all websites to go into fullscreen, but the first seemed to make no difference, and the second will only disable the popup asking for approval, not the notifications afterwards. – miyalys Sep 24 at 16:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.