Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I get an iTunes link, like:

it never opens up in iTunes. I get the "One Moment Please, connecting to the iTunes store" message, but iTunes never gets focus or goes to the link location.

This has been happening for at least a year for me. It used to work (albeit slowly).

I wonder if it has to do with another iTunes problem I'm seeing: Cmd-Tab app switching does not give focus to iTunes. I have to click on the window to switch to it. And if it's hidden, I have to use Expose to find it. Even clicking on the iTunes icon in the dock doesn't do it.

I'm running Mac OS X 10.5 Leopard, iTunes 9.0(70)

share|improve this question
Well, there's a new iTunes version out - 9.0.2. Maybe try uninstalling the version you have and installing 9.0.2? – Jared Harley Nov 2 '09 at 1:05
I'm now running Snow Leopard (10.6.2) and iTunes 9.0.2. Still happening. What I haven't tried yet is a wipe of my HD and fresh install of the OS. Other data point: This only happens for my user account. Other user accounts on my machine do not do this. I tried trashing my iTunes preference files, but that didn't solve either problem. – David Smith Dec 17 '09 at 4:53
I notice that iTunes links work fine in Google Chrome, so it must be something with my Firefox settings. Which means the app-switching problem is unrelated. I'm going to open a new question for that. – David Smith Jan 12 '10 at 6:19
Trying that link in Google Chrome on Windows 7, I noticed something that might be relevant to the issue. Does the focus-changing issue occur with any other applications? I noticed that when the link is clicked in chrome, focus shifts to a dialog asking whether or not to launch iTunes. Perhaps this is failing to take focus in the same way that iTunes is? – Emory Bell Jan 31 '10 at 16:04
1. The focus-changing issue only happens with iTunes. 2. I have it set up such that Chrome/Firefox do not show a dialog asking whether to launch iTunes or not - they just launch iTunes. Or, rather, Chrome does but Firefox does not. – David Smith Feb 25 '10 at 18:24

The link is forcing the browser to ask that the local machine start iTunes to handle the request. Depending on your browser/OS settings, this may not be allowed, and the request will fail.

What web browser are you using?

share|improve this answer
I'm using Firefox 3.5.3. And it seems to work for my friends who use Firefox on the Mac. Also, iTunes is already running, so it doesn't have to start it up. – David Smith Oct 1 '09 at 11:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .