Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had Ubuntu 3.0.23 and installed manually the nVidia drivers 2 months ago. Now took the accumulated updates 3.0.26 and can't boot anymore. After the GRUB menu I get a black screen and a cursor. Is there a way to get into the system and remove the nVidia driver?. I have tried booting with both kernels and also the recovery mode but doesn't work.

share|improve this question

migrated from Oct 9 '12 at 2:23

This question came from our site for professional and enthusiast programmers.

Is there another OS you can boot using the driver/device (is it onboard or discrete)? – Zerkz Oct 8 '12 at 20:54
no, I have one drive dedicated to Ubuntu ... can't boot with none of the available kernels. Is there a command in grub I can run to login in "safe-mode" or anything alike? – Giovanni Azua Oct 8 '12 at 20:55

2 Answers 2

How do I boot into single user mode from GRUB?

  1. Select (highlight) the GRUB boot menu entry you wish to use.

  2. Press e to edit the GRUB boot commands for the selected boot menu entry.

  3. Look near the bottom of the list of commands for lines similar to

    linux /boot/vmlinuz-3.2.0-24-generic root=UUID=bc6f8146-1523-46a6-8b6a-64b819ccf2b7 ro quiet splash
    initrd /boot/initrd.img-3.2.0-24-generic
  4. Change the middle line in (3) by adding the kernel boot parameter single to the end of the line (i.e. after ro quiet splash). For this example you would change

    6a-64b819ccf2b7 ro quiet splash  


    6a-64b819ccf2b7 ro quiet splash single
  5. Press either Ctrl+X or F10 to boot using these kernel options.

share|improve this answer
Thanks! I tried this and doesn't work. I still get the same black screen and cursor. – Giovanni Azua Oct 8 '12 at 21:14

Following the details on this page I gained access to the broken Ubuntu installation and executing the following fixed the issue. After that I took out the LiveCD and rebooted and then I could login normally. I finally reinstalled the latest nVidia driver.

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.nvidia

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.