Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have HostGator VPS server with FFmpeg installed. It allows me to convert .wmv to .flv as well as .mp4 files successfully using the following commands for flv and mp4:

ffmpeg -i WantsABath.wmv -b 600k -r 24 -ar 22050 -ab 96k WantsABath.flv 
ffmpeg -i WantsABath.wmv WantsABath.mp4 

but it won't allow me to convert any file format to .ogg.

I tried using the command:

ffmpeg -i input.mp4 -acodec libvorbis -vcodec libtheora -f ogv output.ogv 

by mondain but no luck with it. I am doubting that my VPS doesn't have libtheora installed. I tried configuring it by using SSH but I don't know how to make sure if it is installed or not. I tried checking with php_info but can't find anything regarding libtheora.

Here's my FFmpeg version:

FFmpeg version SVN-r19795, Copyright (c) 2000-2009 Fabrice Bellard, et al. configuration: --enable-libmp3lame --enable-libvorbis --disable-mmx --enable-shared --prefix=/usr/ --enable-gpl libavutil 50. 3. 0 / 50. 3. 0 libavcodec 52.35. 0 / 52.35. 0 libavformat 52.38. 0 / 52.38. 0 libavdevice 52. 2. 0 / 52. 2. 0 libswscale 0. 7. 1 / 0. 7. 1 This details doean't show libtheor

Can anyone please suggest me something?

share|improve this question

Your configuration string shows --enable-libvorbis, which would allow you to encode to Vorbis audio, however you can't create Theora video nor write to an OGG container.

Also, your version is quite outdated — it's from 2009. Three years is a long time for a tool like FFmpeg, which is constantly developed. Hundreds of bugs have been fixed since then.

You now have the following options:

  1. In your package manager, try to install a newer version if available. That'd be yum install ffmpeg or yum install ffmpeg-devel.

  2. On the FFmpeg download page, you will find links to static builds (like gusari or relaxed), which enable both libtheora and libvorbis as well as several other important ones you are missing, like libx264 (for high quality h.264 video) and libvpx (for WebM).

    Simply download the file, extract the archive, and run the ffmpeg binary with ./ffmpeg instead of the system one. There is no need to ./configure or anything.

  3. Compile FFmpeg yourself, using the right configuration flags. You can find an in-depth guide for compilation under Ubuntu or CentOS, both on the FFmpeg wiki.

share|improve this answer
to install the new version i have to delete the old one ? – user163906 Oct 10 '12 at 9:11
No no, you just download it somewhere, then run the ffmpeg binary, e.g. /home/username/downloads/ffmpeg. You might have to make it executable before with chmod +x ffmpeg. – slhck Oct 10 '12 at 9:12
if i write command using my SSH yum install ffmpeg ffmpeg-devel will it help me installing the new verson ? – user163906 Oct 10 '12 at 9:20
It depends on what Linux distribution you run. The packages provided by yum will always be outdated – how much depends on your distro and when it was released. But give it a shot and see what you get. If not, you can always use the static builds, which is what I would recommend anyway. – slhck Oct 10 '12 at 9:23
min is centos x86_64 should i follow the link – user163906 Oct 10 '12 at 9:26

You could try my free script from here:

This does many conversions: multimedia, audio, images, text, and more. Might do exactly what you want. For Linux, tested on Fedora, Ubuntu, Mint, and others.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .