Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Im trying to access Host files (Destop Folder) from RHEL installed on Virtual Box.

  1. First I Shared a folder from menu bar of VirtualBox.
  2. Then I make a directory in /Media/ubuntushare
  3. Then I tried to mount Destop folder of Host system in /media/ubuntushare

But it return error

mount: unknown filesystem type 'vboxsf'

enter image description here

share|improve this question
up vote 1 down vote accepted

Make sure you have installed the virtualbox guest additions package on the host and then install guest additions on the guest.

First install the guest additions package on the Ubuntu host:

sudo apt-get install virtualbox-guest-additions-iso

Then open virtualbox, boot into RHEL and follow these steps (source):

  1. Install DKMS, a framework that helps with building and upgrading kernel modules and the GNU C compiler (as root):

    yum install dkms
    yum install gcc
  2. Mount the guest additions installation .iso (I have a windows guest but the VBox menus will be the same):

    enter image description here

  3. Install guest additions (again as root):

    sh /media/cdrom/
  4. Modules are the linux equivalent of windows' drivers. The command below will load the necessary module (if it is not there) for mounting the shared folder (as root):

    modprobe vboxvfs
  5. Try mounting the share now:

    mount -t vboxsf Desktop /media/ubuntushare

This, of course, assumes that you have set up the share correctly.

share|improve this answer
I dont know what ur suggested command do. But actually i didn't installed Guest additions infact I tried it but I always run it without sh. And please suggest how to install Guest additions on Host there is no such option. – OmiPenguin Oct 9 '12 at 11:29
@UmairMustafa, see my updated answer. – terdon Oct 9 '12 at 12:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.