Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For the last two days, Outlook has decided it doesn't like URL's. Any email message that comes in containing an URL will show the following in an error dialogue message box when I click on the link:

General Failure. The URL was:
"http:/something.com/somewhere/". The parameter is incorrect

If I copy the link into a browser, it works correctly.

OS is Windows XP SP 3, Microsoft Office 2007 (Outlook), Internet Explorer 8 (also Chrome).

I have, of course, Googled this and the two most popular solutions are:

Solution 1:

  • Add/Remove programs
  • Set Program Access and Defaults
  • Custom tab
  • Make sure a default browser is selected

Solution 2:

  • Add/Remove Programs
  • Select the MS Office 2007 item
  • Click Change
  • Click Repair

I have tried both of these and I still get the problem.

Has anyone else had this problem and solved it with a solution other than those listed above?

share|improve this question
    
Hmmm! Some searches suggest uninstalling IE8 (itintheory.blogspot.co.uk/2012/03/…) but since this the company mandated IE version I don't think I can. –  Simon Peverett Oct 9 '12 at 13:51
    
Turns out I can (and have) uninstall IE8 and it DID fix the problem. Especially as I am using Chrome as my default browser. There has to be a better way to fix this other than ditching IE8 though. –  Simon Peverett Oct 9 '12 at 14:43
    
Well, uninstalling IE8 lasted about a day. Now the problem is back, and I have IE7!!! –  Simon Peverett Oct 11 '12 at 9:26
    
To update. My IS department ran a mystery script that they would not show me the path to, and now it all works again. They don't like it when user's fix stuff themselves. –  Simon Peverett Aug 7 '13 at 9:16
add comment

1 Answer

Fixed it.

Start IE from the desktop icon by right-clicking on it and start it without Add-ons. Then go in and disable any add-on (Manage Add-ons) that isn't what you would expect (i.e., leave stuff from Microsoft, Adobe enabled).

Then try opening a link from the email message. I found three add-ons that I disabled and it works. One was called "Research", one was an MSN Messenger add-on, and the other was a Disqus add-on.

This is in Windows XP. WIndows 7 is probably the same.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.