Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently bought a TL-WN951N PCI card, it gets detected right and the module being used is ath9k.

When trying to set it to master mode however, it prints:

$ iwconfig int1 mode master
Error for wireless request "Set Mode" (8B06) :
    SET failed on device int1 ; Invalid argument.

OS (from uname -a): Linux foo 3.2.0-3-686-pae #1 SMP Mon Jul 23 03:50:34 UTC 2012 i686 GNU/Linux

Anybody knows why?

share|improve this question
    
If you want to answer your own question, just post an actual answer and accept it as the working solution later. Please don't put any solutions into your question :) –  Oliver Salzburg Oct 10 '12 at 13:04
    
ok, thanks, I will do it –  f0o Oct 10 '12 at 13:22
add comment

1 Answer

Well, apparently newer wireless-tools requires hostapd in order to set an wireless extension in Master mode. They also deny manual setting of the Master mode for some reason.

So I guess it's "Solved"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.