Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I regularly set up virtualbox ubuntu setups to run as local webservers. I have set these up several times and never had an issue. However, something has changed:

1)vb guest additions no longer allow me to copy and paste (i'll worry about that later)

2)more importantly phpmyadmin no longer works as installed - Initially going to localhost/phpmyadmin gave a message that the page could not be found.

So followed instructions which told me to do this in /var/www:

sudo ln -s /usr/share/phpmyadmin phpmyadmin

which has created a phpmyadmin directory in /var/www but now I get an error saying: the mysqli extension is missing.

If I run phpinfo mysql and mysqli are listed.

All I have done so far is

sudo apt-get update  
sudo apt-get install apache2
sudo apt-get install php5
sudo apt-get install mysql-server

and

sudo apt-get install phpmyadmin 

I found a post of a similar question which suggested I should do

sudo apt-get install php5-mysql

(I've done this) and edit php.ini and uncomment the line:

extension=mysqli.so

This is not there, so I tried adding it but no joy. I have restarted apache and still no phpmyadmin.

I'm running a windows 7 machine and the guest os is ubuntu 12.04

share|improve this question
    
I personally prefer to use the MySQL Workbench app : mysql.com/downloads/workbench , especially if your adminstering from your Windows 7 machine. The phpmyadmin app is from the days before "MySQL Workbench" was available... –  djangofan Oct 9 '12 at 16:32
    
I did have a play around with that at some point - I abandoned it because the free windows version doesnt work on remote servers. It would be a workaround for this but since all my live servers are running phpmyadmin I would prefer to keep it all consistent if possible. Besides, I don't like to admit defeat if I can help it - this should be simple... it used to be. –  WebweaverD Oct 9 '12 at 16:37
    
The free Windows version DOES work on remote servers. I use it on Amazon EC2 servers all the time. –  djangofan Nov 1 '12 at 22:45

2 Answers 2

Don't forget to restart the apache after the ln command:

sudo /etc/init.d/apache2 restart

share|improve this answer
up vote 2 down vote accepted

Ok I have found the answer to this.

Dont do this step (not needed):

sudo ln -s /usr/share/phpmyadmin phpmyadmin

Dont do this step (not needed):

edit php.ini and uncomment the line:

extension=mysqli.so

Do do this:

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.conf

Apparently this serves to "symlink the phpMyAdmin conf file within the apache2/conf.d/" courtesy of pete fisher: http://blog.peterfisher.me.uk/2012/06/27/solution-to-phpmyadmin-throwing-a-404-error/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.