Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

UPDATE: - I can't find any Local Policy Editor for Vista Home Premium, as suggested. - I did learn about registry keys: allocatecdroms, allocatefloppies, allocatedasd and tried adding these keys (individually and collectively) and setting them to both 0 or 1. There was no positive affect on read access to the DVD root folder - always Access Denied.

ORIGINAL POST: Failing read access to the root folder of a DVD drive in Vista Home Premium laptop using the Guest account - Access Denied. The client is an XP Home PC that can see, but not access, the data in the share.

I'm only trying to read the data DVD - not trying to write/burn anything.

On the Vista laptop, I have:

  • All Firewalls and Antivirus disabled.UAC disabled.
  • Password checking disabled.
  • "Advanced Shared" the DVD drive, with "Everyone" having full-access permissions to the share.
  • Tried adding Guest and Anonymous users having full-access permissions to the share.
  • RestrictAnonymous=0 set in the registry.
  • Both PC's are in the same workgroup (MSHOME)

The XP Home client sees the shared DVD in \Vista_Hostname\ but when I double click the drive icon on the client, I get a popup that access is denied, check with the administrator, etc.

I can share other folders on the Vista PC and see and READ these from the XP Home client.

If I enable password checking on the Vista side, I get a user/password popup, and I can authenticate (using my known Vista account, that happens to have Admin rights) and then I can get to see and read the DVD data.

I need to open this up so that the (default) Guest user can see and access the DVD data files.

share|improve this question

2 Answers 2

Look in your local security policy. (Local Policies --> Security Options). One of the options concerns restricting access to the CDROM/DVD. Check your setting.

share|improve this answer
    
Would surprise me if "Devices: Restrict CD-ROM access to locally logged-on user only" is enabled. –  harrymc Dec 28 '09 at 18:07
    
The other possibility is "Network access: sharing model and security for local accounts", which is probably already defined as "Classic - local users authenticate themselves". –  harrymc Dec 28 '09 at 19:30

Some ideas to try, a bit contradictory to what you did:

  1. Verify the checklist in this article on the Vista machine.

  2. The article Enable Simple File Sharing in Vista contains many steps that you should mostly follow through. It might be better to turn off password protected sharing as described in this article.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.