Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just installed cygwin on Windows 7 x64, and I have installed all the packages I need. I have installed cpio, and I am attempting to extract a file with the following command line in the cygwin console:

cpio -i -H newc /sygdrive/f/_virtual/image.cpio

When I run this, I get no errors, but nothing happens. No extraction. I first tried waiting 5 minutes, 10 minutes, 1 hour, the next evening, but nothing is happening. The cpio archive file is less then 20 MB. The system never ran out of RAM or CPU. It's like nothing happens. The console and the system are not locked. I can kill the command and move on.

What's the problem and how can I fix this?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

cpio -i reads from the standard input.  Try

cpio -i -H newc  <  /sygdrive/f/_virtual/image.cpio
share|improve this answer
    
This worked! Thanks alot Scott! –  user264892 Oct 31 '12 at 22:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.