Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Google Drive on my Windows 7 laptop and began syncing all my files a few days ago. All was well until I needed to search for some documents in my local copy of Google Drive using Windows 7 Search feature.

Windows did not return any results at all. Weirdly, when I turned off Windows indexing for that folder, it began returning results.

I don't mind using windows search w/o the index but sometimes it takes too long to search (especially for keywords inside documents like Word and Excel). It's driving me nuts to the point where I have given up on Windows Search and switched to Google Drive's online search to look for files (not as convenient as I still have to go back go google drive in Windows to locate the folder). Any help appreciated!

share|improve this question

4 Answers 4

up vote 19 down vote accepted

OK, I hope this helps for people who are having problems with Windows 7 Search in Google Drive folder. After a few days of playing around, finally got windows search to work and best of all, search inside files(e.g. word, excel) works too!

  1. make sure security permissions for 3 users (specifically the SYSTEM group) are given FULL access to Google Folder. I'm not sure why my folder only gave my user account access. I realized this only after checking the other folders where index search was working.

FULL Control Security permissions for these 3 users

  1. Indexing is enabled for content. When Google Drive synced my files, it apparently did not set this attribute. The funny thing is that the folders were set but not the individual files inside. I'm not sure who to blame for this. So what I did was go to the Google drive folder properties, clicked on Advanced button, then unchecked "Allow files in this folder to have contents indexed in addition to file properties". After clicking all the OKs and confirming to do this to all folders and sub folders, go back to properties and enable the "Allow files in this folder..." so that it will propagate to all files inside.

Google drive Properties - Disable and enable the below checkbox for this property to copy to all files inside folder

Now Windows search is working for both normal file search and content searching. I'm not sure if this affects Google Drive in any way. But if you are reading this Google, please fix this in your app (unless this was done intentionally to force users to user Google Drive's online search :P).

share|improve this answer
1  
Only the SYSTEM account was needed for me, I ignored the Admin group. –  Scandalon Oct 3 '13 at 17:06

Maybe there is a problem with the index of the Windows 7 search.

You can try to correct it with the Microsoft Fix It tool from support microsoft.
Download the tool and execute it. Select Detect problem and select fix manually.
After some time there is a list of problems and fixes.
Select reset windows search.

After the dialog is finished you problem is hopefully solved.

share|improve this answer
1  
Thanks. Microsoft Fix It tool did not find any errors. After resetting windows search, it still did not solve the issue. Anyway, after banging my head for a few hours against my laptop, I discovered that my Google Drive folder on my laptop did not have the same security permissions as the other folders. After applying the security permissions (Administrator, System, [myusername]) to the folder, windows index started working...sigh. But Search inside files like word still does not return anything in Windows search. –  Joel Oct 11 '12 at 0:53
    
I am having the same problem. The Microsoft Fix It tool did not fix the problem and all my security permissions were correct. I only started developing this problem in the past week or two. It used to work perfectly. –  IThink Oct 16 '12 at 18:19
    
Wait wait. Maybe it is working but it is taking 27 years to display a result. –  IThink Oct 16 '12 at 18:23

I have two computers running Windows 7, one is older and runs Windows 7 32 bit and works perfectly with Google Drive. I just recently got a newer computer running Windows 7 64 bit and it would show some files but would miss most in the Google Drive search.

I did this with the permissions and the index. Now it works perfectly now on the second computer. I might add that I rebuilt the index before it worked perfectly.

share|improve this answer

I don't know why, but moving the Google Drive folder to another drive solves the problem for me. To move the Google Drive folder:

  1. Right click the Google Drive tray icon and select preferences
  2. Click disconnect account
  3. Sign in again, but this time, select Advanced setup before syncing
  4. Change the folder location and point it to a folder on another drive
  5. Sync

BTW, I reported this to Google as a bug. Unfortunately, Nyan (Google Support) tagged is as "answered", even though it is not.

share|improve this answer

protected by Community Feb 4 '13 at 22:22

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.