Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The problem is in browser, ssh,...

Windows:

myservername is resolved to myservername.company.com and both the URLs work fine

Linux:

Only myservername.company.com works here and myservername is not resolved.

Any ideas what might cause this behavior on Linux?

share|improve this question
up vote 6 down vote accepted

If you want linux machines to automatically search dns suffixes then your DHCP server will need to issue the "domain-name" option populated with the suffixes you want to be appended to unqualified domain names (where you just state the host part). The isc-dhcp-server scope directive would be:

option domain-name "company.com";

It is probable that your windows machines are getting their primary suffix from being a domain member.

If you aren't using dhcp, then you can manually add this to your /etc/resolv.conf:

domain company.com
share|improve this answer
    
Thank you for the clarification – user219882 Oct 10 '12 at 11:59
    
Also an option for resolv: search company.com - Will cause the lookup for myservername to first hit myservername.company.com then move on from there to look up names. – WernerCD Oct 10 '12 at 15:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .