Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using the Omnibar (address bar) to search google, the search term is repeated thrice. The search still works, but it is quite annoying, especially when you want to modify your original query. Any idea why, and how to fix it?

Example: When searching for "test" the following URL is produced

https://www.google.com/search?q=test&ie=utf-8&oe=utf-8&aq=t&q=test&ie=utf-8&oe=utf-8&aq=t&channel=fflb&q=test&ie=utf-8&oe=utf-8&aq=t&channel=rcs

  • Google Chrome (Version 22.0.1229.94), freshly installed
  • Mac OS X Mountain Lion
share|improve this question
add comment

1 Answer 1

For some reason, the default settings for the google search engine is incorrect. Go to Preferences, Manage Search Engines. Change the URL for the Google (Default) entry

share|improve this answer
add comment

protected by Community Nov 28 '13 at 13:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.