Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is my network:

This is my network

Dotted lines indicate wireless connections, solid lines indicate Ethernet connections.

I used two ASUS routers and Tomato to bridge my network. So I have have two wired segments and a wireless network provided by the main router connected to my cable modem.

Everything seemed to be fine when I set up the bridge last week.

The main .1 router is set up for DHCP and virtually everything is DHCP with reservations by MAC address. The bridge has .2 assigned to it's LAN and it is set in wireless bridge mode. The .2 router is set in bridged mode and connects wirelessly to .1, providing connectivity for all the devices on its Ethernet ports.

But what I'm seeing today is that Pogoplug 2 (.195) cannot seem to get to the Internet.

It cannot ping 192.168.1.1.

It can ping .2 (it's bridge), .199 (wireless Mac), .197 (wired), .196 (wired) etc.

I am connected from .199 to .195 via SSH.

If I use Tomato's tools on the bridge, it can ping .1, 8.8.8.8 etc, so it seems to be fine.

What am I missing here? Seems like something simple.

Pogoplug2 ifconfig:

[root@alarm ~]# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.195  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::225:31ff:fe05:38bc  prefixlen 64  scopeid 0x20<link>
        ether 00:25:31:05:38:bc  txqueuelen 1000  (Ethernet)
        RX packets 169  bytes 20660 (20.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 89  bytes 11323 (11.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 11  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 4  bytes 260 (260.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 260 (260.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

A PC on the bridged part is fine - pings 192.168.1.1

OSX, Ubuntu, Windows devices on the bridged segment seem to be fine.

Pogoplug, Raspberry Pi have problems. Problem happens on either Tomato and DD-WRT firmwares. I have had a friend confirm what looks like the same problem with a FreeBSD device (but not a Windows client) on a bridged segment like this with Tomato on Cisco-Linksys routers.

Is this configuration or client defects or sensitivities or what?

share|improve this question

migrated from serverfault.com Oct 11 '12 at 0:53

This question came from our site for professional system and network administrators.

    
Not to be flippant but have you tried simply power cycling the WAP's and the Modem? –  joeqwerty Oct 10 '12 at 23:31
    
@joeqwerty Will do (again). I just put a PC on the bridged part and it is fine - pings 192.168.1.1, so seems to be the PgogoPlug - also rebooting that to see. –  Cade Roux Oct 10 '12 at 23:35
    
@joeqwerty not making a difference. –  Cade Roux Oct 10 '12 at 23:40

2 Answers 2

up vote 2 down vote accepted
+100

A friend who happens to be a network administrator and Cisco/router person set up a system which demonstrates the problem and then sent me a solution:

You would think it would have been discussed out there more. Who knows? I really think it's a combination of bugs. When you setup the 2nd router as a wireless bridge, the 1st router should only see the MAC address of the 2nd router's WLAN. It should proxy-arp all clients on its side. The logic of this is explained decently in sections 16.3 and 16.3.1 on this site: http://lartc.org/howto/lartc.bridging.proxy-arp.html

At any rate, I have a workaround for you. On your 192.168.1.1 router, go to Administration -> Scheduler. Enable "Custom 1" and put "arp -d 192.168.1.195" (your PogoPlug IP) in the Command Box without the quotes. Set it to execute every 3 minutes of every day. Shouldn't be necessary, but it's been working for my FreeBSD box connectivity for over 45 minutes.

share|improve this answer

I've had this problem too, but with a specific PC. If I set the IP address of the problem machine statically, it worked. There wasn't anything visibly wrong.

However, I must point out that I switched about a year ago to DDWRT and haven't had the problem since. You could try that.

share|improve this answer
    
For s&g, I just re-flashed the router to DDWRT and put it in client bridge. Again, a PC works fine, but the PogoPlug won't ping .1.1 or go to the Internet. Seems more and more to be a Pogoplug issue. I don't want to, but I'm going to try having that router go ahead and do its own DHCP –  Cade Roux Oct 13 '12 at 22:21
    
I also moved the Raspberry Pi to the bridged segment and it has the same symptoms. The RPi is Debian, while the Pogoplug is Arch. A Windows PC and a Ubuntu PC both have no problems on the bridged segment. –  Cade Roux Oct 14 '12 at 2:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.