Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Today when I first booted my DELL XPS L502X Laptop, I've noticed that the sound is only playing the "System Sounds".

Chrome (YouTube and general web pages), Steam, Games and so on, are not playing. Some of them not even appear on "Mixer" (audio control on botton left bar).

I've already updated the drivers, tried to uninstall all audio drivers and let windows reinstall them both (Audio and Realtek drivers). Also, I've double checked if the "audio" service and its dependencies were started properly on boot, and they were.

What might be happening here?

My Windows Media Player is not opening either, no error message, it just won't open.

Update:

DirectX Diagnosis says everything is OK. I tried to update the DirectX but it says "Internal Error" and force closes.

Update 2:

Just finished booting up on Dell's CD for Diagnosis tool, and finished the audio test, everything seems "OK", but ouviously not.

Update 3:

CCleaner and KLite Codec fixed some registry errors, but the "non-system" sound is not back yet.

Update 4:

Considering reinstalling my OS after formating the whole HD =/

share|improve this question
    
check the DXdiag (direct x diagnosis) C:\Windows\System32\dxdiag.exe for a start, and then do "speaker testing" in the software provided by realtek. hmm, sometimes this stuff can be fixed/reconnected via the software by re-installing the DirectX packages, and the Media Player packages, which will include many DX and playback components. Other things might be a the installing of a codec package that adds layers of un-nessisary things. –  Psycogeek Oct 11 '12 at 4:54
    
Test result was OK "No result was found" for sound components and no other component. Should i just update the Direct X ? –  Marcello Grechi Lins Oct 11 '12 at 11:40
    
Reinstalling Direct X resulted in "Internal Error". And it force closed. –  Marcello Grechi Lins Oct 11 '12 at 11:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.