Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to telnet, to localhost. I am on windows.

Once I got the error 'telnet is not recognized...' I looked online and found that I should do pkgmgr /iu:"TelnetClient".

I did, then telnet localhost (0r 127.0.0.1, maybe with a port at the end), I get error:

Could not open connection to the host, on port 23: Connect failed.

I added the port to the firewall, disabled the firewall.. run as admin..

Please help me get telnet to work! Thank you.

share|improve this question
    
Did you try using telnet to a separate host entirely? – Tillman32 Oct 11 '12 at 1:35
    
I was able to do what I needed, telnet 127.0.0.1 port (I didn't realize I had to put a space, not colon before the port). Still not sure why port 23 doesn't work... – Thalia Oct 11 '12 at 2:03
    
Oh yeah I could have told you that if you showed us what you were typing! :P Glad you figured it out. – Tillman32 Oct 11 '12 at 22:09
1  
Right... I'm going to mark Richie086's answer (the only answer), since I did not know that I needed to have a telnet SERVER installed locally, I only installed a client. Thank you both. – Thalia Oct 11 '12 at 22:16
up vote 1 down vote accepted

Do you have a telnet server installed locally? If not, you will not be able to connect to 127.0.0.1 on port 23. Also, why telnet? some specific reason? Why not just open a command prompt considering you are connecting to 127.0.0.1 and already have a command prompt open.

FYI - I highly suggest checking out a tool called PuTTy. It is a SSH/Telnet/Serial terminal application for windows that allows you to save connection details, set various options for your session, etc. Best of all, it's free!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .