Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After installing the Razer Anansi OSX driver (1.01) from Razer, it appears my function keys have reverted to the default "special" keys. For example, F1 and F2 control the brightness of the screen instead of registering as F1 and F2.

I've tried editing the keyboard preferences (the tickbox which says "Use all F1, F2, etc. keys as standard function keys") but it does not appear to have any effect. I've also tried disabling the mapping in the Razer driver program, but that, too, does not appear to have an effect.

I would like to keep the Razer Anansi driver installed, but I would like my function keys to be the standard ones instead of the special MBP ones.

share|improve this question
Did you manage to resolve this issue? – naithemilkman Jan 18 '13 at 3:16
Nope. I contacted Razer and got my ticket escalated a few times until they stopped responding. I'd still be curious to find a solution to this, but I've stopped trying actively. – almostflan Jan 19 '13 at 0:33
Thanks for replying man. – naithemilkman Jan 19 '13 at 3:00

Press and hold the Fn key and press the gaming key (F13), this will put it in 'gaming mode' (the G light should light up on the top right of the keyboard. All the F keys will then work as F keys. Press the same keys to take it back out of 'gaming mode' if you want the media keys back.

share|improve this answer
I didn't think I'd ever get an answer to this... I'll try this when I get home. Thanks! – almostflan Aug 21 '13 at 23:09
Sadly, gaming mode disables the command key for me. – Daniel C. Sobral Mar 6 '15 at 3:39

I contact Razer and they answered me that the problem is that Apple changed the keyboard standards for a proprietary standard. Razer use an international standard on their keyboards. But... they didn't tell me what to do. I discovered same tha our friend Jawa said... inside game if I disable the game mode, I continue having F keys working right and the command key backs!

Regards! Hellbringher

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.