Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to execute this command

wget -r ftp://$USER:$PASSWORD@$SITE/

But first since there were some special characters (such as '!?') within the PASSWORD I had some problems that I solved by escaping them with '\'..

Now I am facing the problem that special character don't work with the ftp command...(here)

At the moment I get this:

Bad port number

This is because also some numbers are present within the PASSWORD, I tried to single-quote, but without success..

How can I solve, if I would not change the password?

On terminal, on Debian.

share|improve this question

migrated from Oct 11 '12 at 10:41

This question came from our site for professional and enthusiast programmers.

Use the --ftp-user and --ftp-password parameters instead of encoding it into the URL. – Joe Oct 10 '12 at 17:16
@Joe It worked, thanks. If you wanna make an answer I will choose it. – elect Oct 10 '12 at 19:06
up vote 2 down vote accepted

Use the --ftp-user and --ftp-password parameters instead of encoding it into the URL

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.