Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to edit a smarty php template file in Aptana studio 3, and unfortunately it is very very plain, black text on a white background.

I would like to activate syntax highlighting for .tpl files.

I have already tried going to Preferences > General > Content types and have added *.tpl to the HTML and PHP sections under text, but to no avail.

I am running Mac OSX 10.8 Mountain Lion, any idea how I can get the syntax highlighting to work on the .tpl file?

Thanks.

share|improve this question

Try Preferences > General > Content types add *.tpl to php source in the text dropdown.

share|improve this answer
    
Thank you verry much :D – Mathlight May 15 '13 at 6:57
    
TPL works really well with PHP highlighting... I originally thought HTML would work better. – Ray Foss Jul 18 '14 at 12:38

First check whether *.tpl is included in your associated files.

Go to Preferences > General > Editors > File Associations Check in the list whether *.tpl exists, if not add it.

Select *.tpl and if Associated editors is empty click Add and add PHP Source Editor and press OK

Then - as Gabriel Catillo said - go to Preferences > General > Content Types and add *.tpl*to PHP Source in the Text dropdown.

You might need to close and reopen your .tpl files for this to take effect.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .