Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've accidentally press the key Ctrl + Alt + F1. It switches my default terminal to a virtual terminal, and I don't have the folder and user information in the command line anymore. How do I get back to the previous state of my Terminal?

share|improve this question

migrated from stackoverflow.com Oct 11 '12 at 13:59

This question came from our site for professional and enthusiast programmers.

    
Have you try Ctrl + Alt + F[2,3,4,5,6,7]? –  Kulti Oct 11 '12 at 9:21
    
Yes, but It switch to the black screen and ask for password, I've entered the root and user password but not ok. I restarted the system and found out that it's still the same terminal (1) –  HOAI NAM NGUYEN Oct 11 '12 at 9:23
    
Hm... I cannot understand, what do you mean under "default" terminal? (I thought you mean terminal with X-server). –  Kulti Oct 11 '12 at 9:31
    
Well, I don't understand neither. In the default terminal, in the command line I have the name of the current folder and the username, but when I press Ctrl + Alt + F1, it switched to another type of terminal and I have just "$" in the command line. When I type cd /home/... the tab key does not work to help me to type faster. So I want to switch to the default parameter or type of terminal –  HOAI NAM NGUYEN Oct 11 '12 at 9:34
1  
Please, show echo $SHELL output. I think it's /bin/sh. In that case try to run bash. Thanks. –  Kulti Oct 11 '12 at 10:05
show 2 more comments

2 Answers

Ctrl + Alt + F7 usually brings me back to the X-Server, by default, the first X server runs on terminal 7, this same question has also been asked at ask-ubunutu, some people report having to use Alt + F8

share|improve this answer
    
I've tried Ctrl + Alt + F7, it does nothing, Alt + F8 show me a total black screen! When I restart the problem persists –  HOAI NAM NGUYEN Oct 11 '12 at 9:51
    
What build of Linux are you using? –  Gearoid Murphy Oct 11 '12 at 9:53
    
I use debian 6.0 –  HOAI NAM NGUYEN Oct 11 '12 at 10:01
    
The more information you give, the better, what desktop are you using? –  Gearoid Murphy Oct 11 '12 at 10:02
    
I use actually KDE –  HOAI NAM NGUYEN Oct 11 '12 at 10:12
show 1 more comment

Thanks @kulti, The problem of mine is the bash mode, I need to go to Settings->Manage Profiles-> change the name of the profile to bash, and it is just like before!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.