Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running a linux laptop and I set up a VirtualBox under windows XP. My only problem is the VirtualBox doesn't seem to be connected to internet - When I do the connection diagnosis it tells me there is no connection.

I am using an NAT adapter, and I bind the port 80 from my computer to the port 80 of the VirtualBox, and same for the ports 8080, but still no result. I would be grateful is someone could help me to sort this out.

EDIT: thinking of it, what is making the problem hard - and painful - is the absence of error message. If I try to use a given adapter to share my computer's connection with the VirtualBox, and it doesn't work, I have no way to know why. So, it would be really helpful if someone could share a way to access this king of information (is there a log file somewhere or a way to run VirtualBox from command line in a verbose mode?).

Note: it doesn't do much to run from command line:

VirtualBox --debug

EDIT2: when running VirtualBox as root (sudo VirtualBox), I get the following message while trying to run a windows XP box:

Failed to open/create the internal network 'HostInterfaceNetworking-wlan0' (VERR_SUPDRV_COMPONENT_NOT_FOUND). One of the kernel modules was not successfully loaded. Make sure that no kernel modules from an older version of VirtualBox exist. Then try to recompile and reload the kernel modules by executing '/etc/init.d/vboxdrv setup' as root (VERR_SUPDRV_COMPONENT_NOT_FOUND).

Maybe that's a clue of the actual problem.

share|improve this question
add comment

1 Answer

I would try using the Bridged Adapter.

If you installed the Bridged Adapter driver during setup, it should be visible in settings:

Attached to: Bridged Adapter
Name: Name of network card with Internet connection

share|improve this answer
    
Yeah, I tried the BridgeAdapter as well, linking it to my wlan0, but without success. –  S4M Oct 11 '12 at 15:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.