Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've tried to install NFS but I cannot pass through this step where I configure /etc/exports

The file looks as follows:

/home/MYUSER/Documents 192.168.0.2(rw, sync, no_subtree_check)

But when I restart the nfs-kernel-server or run exportfs -ra the following appears:

* Stopping NFS kernel daemon                                            [ OK ] 
* Unexporting directories for NFS kernel daemon...                      [ OK ] 
* Exporting directories for NFS kernel daemon...                               exportfs: /etc/exports:1: syntax error: bad option list
                                                                     [fail]
share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Your exports syntax is incorrect – you cannot have any spaces in the option list. Try:

/home/MYUSER/Documents 192.168.0.2(rw,sync,no_subtree_check)
share|improve this answer
    
I almost cry, thanks a lot, I've been trying this for several hours :') –  poz2k4444 Oct 11 '12 at 17:54
    
Thanks. I wasted my time for this. I think this is a stupid restriction. Almost all languages, scripts ignore whitespaces... –  Sin Jeong-hun Jun 17 at 5:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.