Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 NIC's on my computer. I have connected one with a GigE camera and the other to a switch which in turn connects it to a video server. If only one device (i.e., GigE camera or video server) is connected, both the NIC's work fine.

When I connect both, the one which connects first runs properly and the other device says it has an IP conflict. How do I solve this?

share|improve this question
    
Which IP did you give to NIC #1 and which to NIC #2? –  Hennes Oct 11 '12 at 20:30
    
@Hennes I havent given any IP's. It automatically detects. –  Vinshi Oct 11 '12 at 20:37
    
Let me rephrase that. Which IP does NIC 1 get when you plug it in first. Same question for NIC 2 if you plug it in first. Are they the same? (E.g. because you marked 'obtain an IP address automatically' but set the same fallback IP under the tab 'Alternative configuration') –  Hennes Oct 11 '12 at 20:45
    
@Hannes Both the IP's are the same. They obtain it automatically. –  Vinshi Oct 11 '12 at 20:58
1  
In that case the error is correct and auto configuration is failing somewhere. (During 'normal' use both NICs should not have the same IP.) If you have a DHCP server somewhere on the normal (not camera) side of the network you might want to look at at. Alternatively, set one of the NICs to a fixed IP. Best might be something like a fixed IP to the GigE camera (e.g. 172.16.1.1) and something in the same range to the NIC connecting to that camera. (e.g. 172.16.1.2). Leave the other NIC on auto configure. –  Hennes Oct 11 '12 at 21:02
show 3 more comments

1 Answer 1

up vote 0 down vote accepted

Step 0:

  • Check how to change the IP address of your camera. (E.g. read the manual).
  • Decide which IPs to use. In the example below I will use 172.16.1.1 for the computer and 172.16.1.2 for the camera. If asked use subnetmask 255.255.255.0.
  • Set the camera to this IP. (You will now loose communication with the camera until you set the PCs LAN port to a compatible value.

Step 1:

Configuring the LAN port on the PC.

Log into your computer with an account with administrative rights, then go to [start] [Control panel] and click on [Network and sharing center].

Since you have two network cards you will see two local area network connections.

One of these is connected to your LAN/videoserver. One to the Camera. Select the one which is connected to the camera.

Left click on one of the LAN connections. (This is counter intuitive, since most MS products would use a right click in this place to open a menu with properties as an option)

You should not have this on your screen:

Screenshot of windows 7 LAN tab

Click on properties. This will take you to the this screen:

Screenshot of windows 7 LAN tab - Sub properties

Select the internet protocol version 4 and click on the [properties] button.

This takes you to a third screen. This one is set to Obtain an IP address automatically. Usually this means that the computers does a DHCP request. Think of it as a yell on the network with 'Hey. Anyone out there. I am MAC address. How do I need to configure myself to communicate with you guys'. This will fail if no one gives an answer, or if an invalid answer is given. From your post it is not yet clear what goes wrong, but we will ignore that and simply manually set some working values.

Select Use the following IP address. This will unmask the next three fields.

  • In the field IP adress enter the values 172 16 1 1
  • In the field subnet mask enter 255 255 255 0
  • Press OK

Win 7 TCP/IP configuarion

Step 2:

Testing the new configuration.

Open a cmd prompt via [start] search programs and files cmd.exe

type the following command to send a test packet to your camara.

ping 172.16.1.2

You should get a few lines with similar output:

 Pinging 172.16.1.2 with 32 bytes of data:
 Reply from 172.16.1.2: bytes=32 time<1ms TTL=64

This means that your PC and your camera can communicate. IF this fails then check if you had the right ports (The LAN connected to the camera and not the one to the video server).

Step 3:

If all works plug in the other network cable. Check if all works as desired. If it does make a note of it in your documentation.

share|improve this answer
    
Thanks. It worked. –  Vinshi Oct 12 '12 at 15:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.