Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've wrote a simple batch file to connect to a specific VPN connection using RASDIAL

rasdial MyVPNConnection 

but it always returned the error

691 Access denied because username and/or password is invalid on the domain.

Remote Access Service (RAS) Error Code List

then i tried pointing to my Remote Access Phonebook (Rasphone.pbk) and see what happens

rasdial MyVPNConnection /phonebook:%userprofile%\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

and still there was an error 691.

I've then unchecked the following

VPN Options tab

but still the same problem was reported when executing my batch file.

share|improve this question
up vote 8 down vote accepted

The problem was that my VPN connection was using Secure Socket Tunneling Protocol (SSTP)

VPN Security tab

and RASDIAL can't connect to such VPN connection as:

RASDIAL.EXE provides unattended dialing. It does not support the following features available in RASPHONE.EXE: prefix/suffix, auto-redial, change password, retry authentication, statistics, operator assisted dialing, and connections requiring Terminal mode input.

RASPHONE and RASDIAL: Tips and Differences

After i've figured that out i've used RASPHONE to make a connection passing the location of my Remote Access Phonebook (Rasphone.pbk)

rasphone -d MyVPNConnection -f %userprofile%\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

And everything worked fine.

To disconnect you can still use RASDIAL

rasdial MyVPNConnection /disconnect

share|improve this answer
    
RASPHONE works like a charm thanks! – Peter Feb 19 at 18:35

Create a shortcut to the phonebook file works pretty well too.

%userprofile%\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk

Screenshot of shortcut and what it opens

share|improve this answer
    
Please read the question again carefully. Your answer does not answer the original question. – DavidPostill Jul 14 at 8:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .