Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Everytime I click on a link from within Mac, parallels boots up my Windows VM and opens the link there. That's super annoying and I haven't found a configuration to change it.

In the settings of my Windows VM there is an option where to launch the webbrowser. However that seems to only affect links that I open from within my Windows session.

UPDATE

I just stumbled across this answer:

How to disassociate a file type with an application in Mac OS

So I disabled "share windows apps with mac" completely. Also this seems to be overly protective it at least does the trick. I think it also deactivates that running windows apps show up in the dock but I don't care that much about that anyway.

share|improve this question

1 Answer 1

Open up Safari and go to its Preferences.

Here, under General, make sure the default web browser is not any Windows application that Parallels offers, but one of the native OS X apps instead, like Safari, Firefox, Chrome, what have you.

The culprit simply is that Parallels will offer virtual Windows applications as native applications to OS X, which may be useful for common Windows files or Microsoft Office documents, but probably not links themselves.

You can further examine associations between URL schemes or filetypes and applications with RCDefaultApp.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.