Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed English Windows 8 x64 on my notebook and selected Slovenian as locale during installation. Like so:

enter image description here

The problem I'm having now is that my tiles on start screen display in Slovenian even though my installation is English. I've also edited languages, adding English (British) on the list and putting it on top of Slovenian, but tiles still use Slovenian.

enter image description here

All previous Windows versions were able to have English UI with a particular locale for input, time, dates, currency etc.

How can I do the same in Windows 8?

share|improve this question
add comment

3 Answers

up vote 11 down vote accepted
  1. Open the Clock, Language, and Region section from the Control Panel:

    enter image description here

  2. Open the Language panel:

    enter image description here

  3. Here we can see the issue:

    enter image description here

    To resolve your language conflict, add a new language enter image description here

  4. Open the English language catalogue:

    enter image description here

  5. Pick whatever English language you prefer and Add it:

    enter image description here

  6. Open the Options for your newly added language and add a new input method:

    enter image description here
    enter image description here

  7. Pick the Slovenian keyboard layout, add it and save your setup:

    enter image description here

  8. You can now Move up your new configuration and Remove the old one.

    enter image description here

    Your date, number and time formats should still be set to Slovenian:

    enter image description here

  9. Restart Windows.

  10. Success

    enter image description here

share|improve this answer
    
-1 for a very detailed answer :P –  avirk Oct 28 '12 at 14:15
1  
What i figured out yesterday as well, nice answer. –  Matsemann Oct 28 '12 at 14:52
add comment

I think the answers to your problem may lie in the Windows 8 language Advanced settings and Region settings. Here's a way to change input:

Press the Windows logo key + space. While holding down the windows logo key, press space until the input you want is highlighted. That input will now be in effect.

Here's a way to change currency, time, dates, etc:

Go to Control Panel, and click the Change date, time, or number formats. On the Formats tab of the Region window, select the country whose formats you want on your computer. Click the Additional setting button on the lower, left corner (above OK) of the Region window. You can select number, currency, time, date, and ather tabs to choose options.

Going back to the Region window, select the Location tab. Select United States (or United Kingdom) from the drop down. Click Apply. Click OK.

On the Region window, select the Administrative tab. Click the Copy Settings button. If you are satisfied with the settings for Current User, select the check box next to Welcome screen and system accounts, which will apply your language choices to more areas of the interface.

Restart your computer.

share|improve this answer
add comment

Oliver Salzburg's answer is very good and complete, but it did not solve the issue for Belgian/Dutch language and keyboard.

I wanted the tiles in English and the keyboard in "Belgium (Period)". After reading this post and some rebooting, trial and error I found my solution.

My settings were these:

image description here

  1. First language: English (UK)
    • Keyboard: English (UK)
  2. Second language: Dutch (Belgium)
    • Keyboard: Belgian (Period)
    • Date/time: Dutch (Belgium)
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.